Ask a Question

Getting "The window was destroyed during method execution" error in TestExecute on windows server

Occasional Contributor

Getting "The window was destroyed during method execution" error in TestExecute on windows server

When trying to run TC script on Windows server 2016 getting error - The window was destroyed during method execution" after the url opens in chrome browser.

Script runs fine in my desktop but in server it returns this error.

Can anyone help?

SmartBear Alumni (Retired)

Community Heroes, thank you!


Hi @Shehnaz it looks like the Community requires more info from you to carry on with the investigation.

Have you solved the issue? If not, please provide the needed data.

Sonya Mihaljova
Community and Education Specialist

Hi @Shehnaz 

Hi There, 


I have exactly the same issue too.

I have a Chrome test that works perfectly on 2 W7 machines and returns error msg "window was destroyed during method execution " with a W Server 2016.

I have to fix. @BenoitB  Asks you to try with Aliases , I have done it and it's the same issue.


In my situation , the distroyed object is somthing like that :




then I change with : 



> same behaviour, I'm wondering why ?


(Hey salut benoit, c'est cool de se retrouver ici 🙂 ! )

(Hey benoit, cool to see you back here ! )

I think this is time to call the Support team because you are able to reproduce systematically the problem.

Just one question, if you test any other web page like a page in google or yahoo, do you have same problem, working on W7 and not on WS16 ?


Bah c'est le lieu ou l'on cause ici ;^)

Un sourire et ça repart

Good Idea @BenoitB , I 'll made a lab tests with the Smartbear website..

Then find others similar topics in the community...

and then... A least open a support case with the lab example easy to reproduce.


It looks like not to be a time-out matter, I add a 30sec delay  objets still unreachable.

Any other idea @tristaanogre  ?

I thought it was a bad settings with Chrome Smartbear Add-On but exaclty the same settings with the one W7

I thought it was also again an SSL settings with Chrome ,....  but not...

Yes because, I just cant access to my website from Chrome just before this new issue,.. and now it seems to bo ok with SSL in chrome, I import a Cert.PFK file and it looks good.

Any other idea ?

SmartBear Alumni (Retired)

 @Shehnaz , @Nikolayev which version of TestComplete are you using? I found a support case with a similar issue and it was solved by updating to TestComplete 14.4.

Sonya Mihaljova
Community and Education Specialist

Hi @sonya_m ,

TC Version is 14.30.743.7 x64.  

Same player shoot again !  ^^


I tried to reproduce with the smartbear web site and then open a case as suggested by

@BenoitB   ....  But can't open a Case, because everything works fine with SmartBear Website


No more ideas came to me for the moments.

If I have one, I'll let you now...







SmartBear Alumni (Retired)

Hi @Nikolayev , maybe you could consider updating first? I see that you are using not the latest version.

If this doesn't help, contacting support would be the best next step.

Sonya Mihaljova
Community and Education Specialist

Showing results for 
Search instead for 
Did you mean: