Ask a Question

Cannot connect to the data source in TestExecute

Occasional Contributor

Cannot connect to the data source in TestExecute


I have a problem connecting my data source when i run my tests on TestExecute (excel file 2013), but when i run it from TestComplete the data source is connected without any problem. 

The location of the file is on a shared folder and both PCs have access.

As I already mention, the problem doesnt exist using TestComplete.

Thanks in advance,

Esteemed Contributor

Excel connectivity has to do a lot with the ACE drivers installed on the machine.  And that is also relevant to bitness (32-bit versus 64-bit).   Make sure that when you execute via TestExecute, you are running the same bit version you are running TestComplete.

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
SmartBear Alumni (Retired)

Thanks for the reply, tristaanogre.

@trajmo, is this what you were looking forward?

Tanya Yatskovskaya
SmartBear Community and Education Manager

Showing results for 
Search instead for 
Did you mean: