Ask a Question

Breakpoints and Pause not working

New Contributor

Breakpoints and Pause not working

Hey all I am setting breakpoints in my code and they are not stopping the execution of the code. Also I am not able to stop the scripts from running by clicking the pause button as well. I am running Test Complete 7.52.678.5 on this machine anyone have any ideas?


Hi Kris,

Try reinstalling Microsoft Script Debugger.

Does this help? If it does not, try reinstalling Windows Script.

Does the issue disappear?

TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Contributor

Sorry for the slow response, things have been busy and I have just had to deal with it for the time being. I ran both installers but still no stopping at break points. The pause button does not work when a script is running as well, you can see the button push but it does nothing.


I had the same issue but resolved after installing script debugger
Champion Level 3

Hi Kris,

Do you have VisualStudio installed on the problematic box?

If you do, then the following may appear to be relevant:

Also have a look at this link:
  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
New Contributor

OK, I read through those articles. I did not have the key in the registry it was looking for so I registered the pdm.dll. Tried it and still no stopping on breakpoints. I do not have Visual Studio Installed but I looked anyway and I had the VS7DEBUG folder so I renamed it then reinstalled the MS Debug. Still no stoppie. 😞 I do have Turbo Delphi on my machine and I am testing a Delphi App if that makes a difference.

Hi Kris,

Do you use scripts or KDT?

Please make sure that the Enable Debugger button on the Test Engine toolbar is activated.

Also, please check whether debugging works for DelphiScript / VBScript projects.
Dmitry Nikolaev

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Contributor

After the steps above did ot work I decided to try everything again fresh. So I closed out of everything rebooted ran all the steps again, rebooted again and tried it and my breakpoints are now working. There must have been a file locked or something when I ran the install before. Everything is working now, thanks for your help!!

Showing results for 
Search instead for 
Did you mean: