Ask a Question

Azure DevOps Pipeline - Intermittent "Unable to navigate to <url> page" error

TommyTester
Occasional Contributor

Azure DevOps Pipeline - Intermittent "Unable to navigate to <url> page" error

Hello,

 

I am experiencing an intermittent issue when running my project via TestExecute, on a self-hosted agent.

 

Several pipelines will run successfully, one after the other, then I will start receiving the an "Unable to navigate to <url> page" on each test case. The detail in the output is:

TommyTester_0-1653312308873.png

Logging into the agent, I can see that the Smartbear Test Extension is (still) installed. The only workaround (which doesn't work 100% of the time) is to logon to the agent, then disconnect without doing anything. 

 

Has anyone else encountered a similar issue?

3 REPLIES 3
Marsha_R
Community Hero

Let's narrow things down a little.

 

If you run the test using TestComplete on the same machine, does it run without error?

If you run the test using TestExecute on another machine, does it run without error?

 

 


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
TommyTester
Occasional Contributor

We only have one self-hosted agent configured.

 

If I was to login to it and run several back to back projects using either TestComplete or TestExecute, I don't encounter the issue. Likewise for other machines that aren't configured as agents.

 

The problem only seems to arise on the third or fourth back to back run, when the run has been triggered from the pipeline.

I suggest contacting Support directly with this issue.  Here's the link:

https://support.smartbear.com/testcomplete/message


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
cancel
Showing results for 
Search instead for 
Did you mean: