cancel
Showing results for 
Search instead for 
Did you mean: 

Problems installing TestComplete 14.2 on WIndows 10

SOLVED
Occasional Contributor

Problems installing TestComplete 14.2 on WIndows 10

Yesterday I was upgradiing from the previous version (14.10 I think), to 14.2 on two machines, one of our CI machines and my own workstation.

 

Installation on the CI machine went smoothly.

 

When I went to install on my machine, I started having errors. I had several applications open, and let it try to close and restart them after install. Unfortunately, after the install, I can no longer open TestComplete without it crashing immediately.

I've tried uninstalling, rebooting, repairing, none of them seem to work. I've even tried out clearing a few registry keys in case something was holding on to it.

 

Attached is a screenshot of one of the errors I'm seeing.


Any advice/ideas? This is the first failure I've had for an upgrade, and I'm a bit worried about recommending we update to the latest version now.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: Problems installing TestComplete 14.2 on WIndows 10

It turns out that an overzealous corporate antivirus was the problem. IT informed me and now it all works.

View solution in original post

2 REPLIES 2
Community Hero

Re: Problems installing TestComplete 14.2 on WIndows 10

If it was me, I would uninstall, make sure all the directories are gone, then install from scratch and restore my project from backup.   Or you can always contact Support directly.  Here's the link:

https://support.smartbear.com/message/?prod=TestComplete

 

And stop messing with the registry!  Nothing good ever comes from that.

 

Highlighted
Occasional Contributor

Re: Problems installing TestComplete 14.2 on WIndows 10

It turns out that an overzealous corporate antivirus was the problem. IT informed me and now it all works.

View solution in original post

New Here?
Join us and watch the welcome video:
Top Kudoed Authors