cancel
Showing results for 
Search instead for 
Did you mean: 

TestComplete 14.74 unable to identify objects in Iframe using Chrome

SOLVED
JamesP
Occasional Contributor

TestComplete 14.74 unable to identify objects in Iframe using Chrome

Hello,

I've had a look around the messages and have not found a proper answer to the above question.

I hope you can help!

 

Using Keyword tests, Xpath or Native TC identifiers and Chrome 89.0.4389.90 TestComplete is unable to identify any objects within the Iframe below:

JamesP_0-1616595053388.png

What is strange is that it can if I use IE 11.0.9600 it identifies them correctly.

I am unable to run the same test again on Chrome or Edge.

The objects identified in IE have only one entry which uses the aira-labelledby form:

[aria-labelledby='ButtonName'] > .btn:nth-child(1)

 

Any ideas how to get around this blocker so we can record and run them in Chromium browsers?

 

Thanks,

James

1 ACCEPTED SOLUTION

Accepted Solutions
JamesP
Occasional Contributor

Re: TestComplete 14.74 unable to identify objects in Iframe using Chrome

The solution is to use the following switches when you launch Chrome:

 

"C:\Program Files (x86)\Google\Chrome\Application\Chrome.exe --disable-web-security --disable-site-isolation-trials --user-data-dir="C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default"

 

JamesP_0-1617029583441.png

All my tests in Chrome and edge now can access the objects in the Iframe.

Thanks to the Smartbear support for providing this solution.

 

 

View solution in original post

2 REPLIES 2
sonya_m
Community Manager

Re: TestComplete 14.74 unable to identify objects in Iframe using Chrome

Hi @JamesP !

I've found your support request, could you confirm the suggested solution worked?

>Try running TestComplete under the administrator account and check if the problem still can be reproduced.

 

 


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
JamesP
Occasional Contributor

Re: TestComplete 14.74 unable to identify objects in Iframe using Chrome

The solution is to use the following switches when you launch Chrome:

 

"C:\Program Files (x86)\Google\Chrome\Application\Chrome.exe --disable-web-security --disable-site-isolation-trials --user-data-dir="C:\Users\<username>\AppData\Local\Google\Chrome\User Data\Default"

 

JamesP_0-1617029583441.png

All my tests in Chrome and edge now can access the objects in the Iframe.

Thanks to the Smartbear support for providing this solution.

 

 

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors