Ask a Question

the exclamation point is inserted randomly in my mail

SOLVED
m_essaid
Valued Contributor

the exclamation point is inserted randomly in my mail

Hi,

Send a mail which resume all the tests I make.

But randomly an exclamation mark is inserted in some places of the mail.

When I get this "!" within a sentence, it's not pretty but it's harmless.

When I get it in a <a href.... , it brokes the link. Which is really annoying.

I don't use global variables. I write in a txt temp file my HTML code, and put it in the body of the mail function.

Anyone could help ?

Thank you in advance,

Mehdi

1 ACCEPTED SOLUTION

Accepted Solutions
Ryan_Moran
Valued Contributor

Re: the exclamation point is inserted randomly in my mail

Possibly this variable MsgErreur exceeds 1024 characters.


''-Praise the sun and Give Kudos.''

View solution in original post

5 REPLIES 5
Ryan_Moran
Valued Contributor

Re: the exclamation point is inserted randomly in my mail

Are you using a CDO message to send the email?

Can you post your function that compiles and sends the message, a sample of your tmp file that experiences the issue, and whatever function writes the tmp file?


''-Praise the sun and Give Kudos.''
m_essaid
Valued Contributor

Re: the exclamation point is inserted randomly in my mail

Hi Ryan,

 

Yes I'm using CDO Messages.

 

A part of the temp file :

 

<p>
<FONT face="calibri">example of text</FONT><BR />
<FONT face="calibri" color="green"><B>example of successful test.</B></FONT>
<p>

 

 

I debugged the tmp file when it is sent to the SendMail function. There is no exclamation mark.

 

The path of the link is specified like this in the procedure that calls SendMail function :

 

if SendEmail('sender',
'receiver',
'Tests',
LireCorpsMail() +
'<P><FONT face="calibri"><a href="W:\SCENARIOS_TEST\TESTS_COMPTA\RapportCompta' + Suffixe + '.mht">Cliquez ici pour lire le rapport.</a></FONT></p><P>' + MsgErreur + '</p>',
'') then
Log.Message('Message sent.');

 

LireCorpsMail is just a method that reads the temp file.

 

When I debug this call of the SendMail function there is no exclamation mark.

 

When I receive the mail, there is one in the middle of a link, in example : 12_03_! 2015

 

Thanks for your patience,

 

Mehdi

 

Ryan_Moran
Valued Contributor

Re: the exclamation point is inserted randomly in my mail

[Edit]

Scratch that last reply. Didn't notice you're using the built in SendEmail function.

This seems more like the issue you're seeing:

 

Link here.

 

You likely need to have embedded line breaks as suggested by that link. I.E. "\r\n"


''-Praise the sun and Give Kudos.''
Ryan_Moran
Valued Contributor

Re: the exclamation point is inserted randomly in my mail

Possibly this variable MsgErreur exceeds 1024 characters.


''-Praise the sun and Give Kudos.''

View solution in original post

m_essaid
Valued Contributor

Re: the exclamation point is inserted randomly in my mail

 Hey Ryan that's great, thank you very much.

In fact as you said the .HTMLBody could not be much longer than something like a thousand characters.

And HTML markups like <BR /> or </P> are not CRLF.

 

So I put at the end of each test a write of Chr(10) + Chr(13). (CRLF)

🙂

cancel
Showing results for 
Search instead for 
Did you mean: