cancel
Showing results for 
Search instead for 
Did you mean: 

rest service xml payload disappears from editor

Occasional Contributor

rest service xml payload disappears from editor

I have a test case where in my tests I compare the response from an old service to the response from a new service. The endpoints to the two services are different. I'm supplying the request payload for the old service as XML and the payload for the new service is JSON. When I run the tests that I have set up, they are both successful. Each one calls the appropriate service and returns a valid response.

The problem I'm having is that when I close the editor for the old service, the XML is not retained. The result is, every time I want to run the test I have to paste the XML into the request tab of the editor. Also, if I click form tab the XML values are deleted and I have to paste it again. If I click the outline or raw tab, the XML is retained.

That is not happening on the tests for the new service. The JSON that I paste into the request tab is there when I reopen the editor. When I click the tabs (form, outline, raw) the JSON is retained.

My workaround is that I open the tests for the old service and paste the XML into the editor for each test (there are four), then run the four tests. Then I run the tests for the new service. As long as I keep the tests for the old service open in the editor, the data is "cached", so the comparisons can be done.

I have clicked around to see if there is a setting I can change to get the XML to stay in place, but I have not found anything. Granted, I am new to using ReadyAPI, so I'm not sure if I'm looking in the right place. I have searched to see if this is a known issue, and I cannot find this scenario described by anyone else.

Can someone point me to a solution?

 

2 REPLIES 2
Community Manager

Re: rest service xml payload disappears from editor

Hi Jstrauss64,

 

Are you using the latest Ready! API version? Please make sure that the issue persists in the latest maintenance build - https://support.smartbear.com/downloads/readyapi/nightly-builds/

 

If the issue is reproduced, I would appreciate it if you sent us a video that demonstrates the problem. To record a video, you can use Jing - a free screen capture tool ( http://www.jingproject.com ).

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

Re: rest service xml payload disappears from editor

Tanya, I am using the 1.4.1 version of ReadyAPI.

New Here?
Join us and watch the welcome video:
Watch the new Interview
Top Kudoed Authors