cancel
Showing results for 
Search instead for 
Did you mean: 

SoapUI Pro empty tags disappear when the question marks are removed

soapui_savvy
Frequent Visitor

SoapUI Pro empty tags disappear when the question marks are removed

This has been a subject of inconvenience. Whenever I remove question marks (?) in the soap request like the example below, I see empty request (upon closing the request window and relaunch). Please find below (before and after) for more information:

 

Soap Request (before)

 

 

<soapenv:Body>
      <abc:getAbc>
         <!--Optional:-->
         <abcSearchRequest>
            <!--Optional:-->
            <abcIdentifier>
               <!--Optional:-->
	       <idNumber>?</idNumber>
               <!--Optional:-->
	       <locationNum>?</locationNum>
               <!--Optional:-->              
               <errorIdentifier>?</errorIdentifier>
            </abcIdentifier>            
            <!--Optional:-->
            <iidVersion>?</iidVersion>
         </abcSearchRequest>
      </abc:getAbc>
</soapenv:Body>

Now removed questions marks for the three tags : idNumber, locationNum, errorIdentifier

 

 

Soap request(Upon Relaunch)

 

<soapenv:Body>
      <abc:getAbc>
         <!--Optional:-->
         <abcSearchRequest>
            <!--Optional:-->
            <abcIdentifier>
               <!--Optional:-->			   
               <!--Optional:-->			   
               <!--Optional:-->                             
            </abcIdentifier>            
            <!--Optional:-->
            <iidVersion>?</iidVersion>
         </abcSearchRequest>
      </abc:getAbc>
</soapenv:Body>

I do not want the three tags to not show up (disappear) in the xml tab of the soap request. How can I ensure that the three tags are still visible in the soap request when you remove the question marks?

 

thanks

soapui_savvy

 

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors