Forum Discussion

Guhan-B's avatar
Guhan-B
Occasional Visitor
29 days ago

Will SOAP UI 5.6.1 work with JDK 8

I am trying to use SOAP UI 5.6.1 with JDK 8. I am using the soap.jar for some integration. 

1 Reply

  • Humashankar's avatar
    Humashankar
    Champion Level 0

    Hi Guhan-B 

    SOAP UI 5.6.1 will not work with JDK 8

    Kindly try the below possibilities

    • If you're strictly tied to using JDK 8, you can consider downgrading to SOAP UI 5.4.0
    • If possible, the recommended approach is to upgrade your Java Development Kit (JDK) to a more recent version, such as Java 11 or 17 (the latest LTS version
    • This ensures compatibility with SOAP UI 5.6.1 and potentially provides security fixes and performance improvements.

    SOAP UI 5.6.1 requires a newer Java version than 8.

    Consider upgrading your JDK if possible.

    Downgrade SOAP UI if necessary but be aware of potential security issues.

    If using soap.jar independently, verify its compatibility with JDK 8

    Hope this helps - Happy to help further!!
    Thank you very much and have a great one!
    Warm regards