Ask a Question

Petstore demo API is not working anymore

thesse
New Member

Petstore demo API is not working anymore

First of all: Thanks a lot for hosting the Petstore demo API. I have been using it extensively to test and demo SoapUI for REST for a long time already.

 

Unfortunately, there is an issue that first appeared about three weeks ago.

 

When you create a new pet with a new petID, GET /pet/{petID} will intermittently respond with the right pet and an error message (about 50% of the time). It seems the Petstore API switches between two datastores in the back-end?

 

Thanks for looking into this! I would like to continue using the Petstore API!

3 REPLIES 3
nmrao
Community Hero

Re: Petstore demo API is not working anymore

Oh, that is unfortunate. May be they switched to OpenAPI 3.0? If so, that is not supported in SoapUI yet, I believe.
Any way, pet store is external to this soapui community.


Regards,
Rao.
richie
Community Hero

Re: Petstore demo API is not working anymore

Hey @thesse,

If youre getting successful responses 50% of the time, id suggest that maybe they load balanced the endpoint and forgot to enable on the second balancer (or something similar).

Dont think you can do much as its 3rd party api/endpoint.

I know a couple of the other demo endpoints dont work anymore. Have you checked the others to see if you could use an alternative?

Cheers,

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
nmrao
Community Hero

Re: Petstore demo API is not working anymore

In such cases, would create a REST mock service.


Regards,
Rao.
cancel
Showing results for 
Search instead for 
Did you mean: