Ask a Question

Soapui Maven -Exception in request: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

shubhimu
Contributor

Soapui Maven -Exception in request: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

Hi,
I am getting below error in soap ui 5.4 version when running my project through maven.
Although in soap ui its working fine after adding ssl settings.
SoapUIMultiThreadedHttpConnectionManager$SoapUIDefaultClientConnection] Connection shut down
19:26:28,791 Error [WsdlSubmit] Exception in request: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated
19:26:28,791 ERROR [SoapUI] An error occurred [peer not authenticated], see error log for details
javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated
at sun.security.ssl.SSLSessionImpl.getPeerCertificates(SSLSessionImpl.java:431)
at org.apache.http.conn.ssl.AbstractVerifier.verify(AbstractVerifier.java:128)

Java version is 1.8.
@smartBear can you please let me know the fix for this.

Thanks,
Himanshu

8 REPLIES 8
avidCoder
Super Contributor

Fix to this problem is to add - 

 

-Djsse.enableSNIExtension=false

The path -  home/soapui/bin/soapui.bat. 

Thanks for the reply..
..i still have a doubt here i am running my soapui project from maven so how would changing the bat file will suffice the purpose. Dont we need to add some plugin/dependency in pom.xml for this or may be something we need to pass in maven goal.

Kindly confirm and correct my understanding.

Could you please tell me what is your java version and maven version? May be its compatibility issue. And try adding this plugin :-

 

<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
<configuration> 
<arguments>-Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true</arguments>
</configuration> 
</plugin>

Still not working after adding this plugin in pom.xml..

maven version is 3.8 and java version is 1.8

@nmrao Would you like to give some suggestions for this problem?

@TanyaYatskovska : Request you to provide solution around this issue.

@nmrao @avidCoder 

i am also facing the same issue.

i am using maven 3.6.0, jdk 1.8 & soapui-maven-plugin:5.2.1

what i tried:-

1) imported the .crt file to the cacert file into the jre->lib->security

2) mvn test -Djavax.net.ssl.keystore="keystore file path" -Djavax.net.ssl.keyStoreType="JKS"  -Djavax.net.ssl.keyStorePassword="password"

3)mvn test -Djsse.enableSNIExtension=false

4)mvn test -Dt="soapui-settings.xml"

5)mvn test -Dmaven.wagon.http.ssl.insecure=true -Dmaven.wagon.http.ssl.allowall=true

issue description:-

i am having 2 services A & B

A need basic authentication in that we are providing username & password

B need SSL certifcate & in headers tab we are required to pass header-Key & value.

set the ssl settings in preferences and executed it's working fine.

but when trying to execute the same project using maven.

service A is working fine but Service B is throwing SSLexception : peer not authenticated.

 

any help would be appreciated !!

 

Thanks 

cancel
Showing results for 
Search instead for 
Did you mean: