Ask a Question

ReadyAPI 3.9.2 - Deactivate check for incorrect endpoint?

SOLVED
Cekay
Contributor

ReadyAPI 3.9.2 - Deactivate check for incorrect endpoint?

Release Notes 3.9.2

Now, ReadyAPI checks an endpoint format and posts an error message to the log in case the endpoint is invalid. It helps you find the cause of the test failing when you, for example, misprint the endpoint.

 

Is there a way to deactivate this check? ALL my tests are failing because of this change. My tests were working with 3.9.1 so the endpoint is not invalid.

 

 

Thu Aug 26 13:33:26 CEST 2021: ERROR: com.eviware.soapui.support.IncorrectEndpointException: An incorrect endpoint is specified for the request [xxxxx xxxxx]

 

 

 

15 REPLIES 15
W89267
Frequent Visitor

Not solved in 3.10

manfredt
Occasional Contributor

Got this from the support:

 

We are glad to inform you that we have just released ReadyAPI 3.10.0 in which you can disable the endpoint check by passing the following parameter:
-Dreadyapi.skip.endpoints.checks=true

Depending on the way you run ReadyAPI, provide the parameter in the .vmoptions file or the .bat\.sh file. To learn how to do this, please see the Modifying Advanced Settings help topic.

Adding the option to the vmoptions worked for me.

PrathapR
Frequent Contributor

Hi @manfredt,

 

May I know how to add this parameter to .bat file.

 

My .bat file text looks like below (which we run from task scheduler):

 

cd C:\Program Files\SmartBear\ReadyAPI-3.10.0\bin
testrunner.bat -J -f "D:\ReadyAPI_Project\API_Automation\CMDReports" "-RJUnit-Style HTML Report" -FXML "-EDefault environment" "D:\ReadyAPI_Project\API_Automation\API_Automation-readyapi-project.xml"

 

after looking your work around. I tried to add url check parameter in different ways but it's not working(example below)

 

cd C:\Program Files\SmartBear\ReadyAPI-3.10.0\bin
testrunner.bat -J -f  "-Dreadyapi.skip.endpoints.checks=true" "D:\ReadyAPI_Project\API_Automation\CMDReports" "-RJUnit-Style HTML Report" -FXML "-EDefault environment" "D:\ReadyAPI_Project\API_Automation\API_Automation-readyapi-project.xml"

 

Could you please anyone help to by pass url check while running projects through .bat file from task scheduler, any help appreciated and thanks in advance.

Hi @PrathapR 

He didn't modified his bat-file but the vmoptions. It also worked for me.

Just add  -Dreadyapi.skip.endpoints.checks=true to that file and start ReadAPI

Cekay_0-1633453044873.png

Have a great evening.

Cheers

PrathapR
Frequent Contributor

 Thank you @Cekay for you replay.

 

Yes, I did update vmoptions file, and it's working fine for me from executable run(ReadyAPI GUI) but it's still throwing error if we run projects from .bat file in task scheduler.

Asper my understanding, we need to update .bat file with this url check by pass parameter, which is I'm not sure how to do and looking for help. (Tried couple diff ways like my above example, it didn't work )

 

Thanks!!

manfredt
Occasional Contributor

Hi @PrathapR,

 

this is how i did it and it seems to work. I added the option in ReadyAPI's testrunner call as a custom argument and then checked the result.

Long story short: it puts the argument at the end, so it looks like this:

testrunner.bat -sTestsuite -cTestCase -r -a -j -f${WORKSPACE} project.xml -Dreadyapi.skip.endpoints.checks=true 

cancel
Showing results for 
Search instead for 
Did you mean: