Ask a Question

[READY API 2.7.0 ] when Rest request is sent with an attribute having value ñ

New Contributor

[READY API 2.7.0 ] when Rest request is sent with an attribute having value ñ

Hi Team,

If  I am sending request with attribute ("region":"Español-Iberica and Southern Europe") it converts ñ -> �  (Espa�ol-Iberica and Southern Europe) how can i stop converting this request ?

if i send the same request through postman its working fine.



Community Hero

Hey @hemanth_peddi,

It looks like the character set you have configured in ReadyAPI! isn't recognising the character 'ñ', and so is replacing it with a placeholder character when you try and submit the request.
I think you need to find out what charset the system you're testing is supposed to support (that includes a ñ character and change ReadyAPI!s char encoding property to that charset.

You change the charset encode for ReadyAPI! by doing the following:

Navigate to your .vmoptions file


1. Edit the above mentioned file by adding the entry as -Dfile.encoding=charsetvalue (e.g. UTF-8)

2. Save the file

3. Restart the SoapUI


This chqr encoding value that is set can be checked by Help >> System Properties >> file.encoding



if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

My issue got resolved after changing Encoding Option in Rest request to "UTF-8". Thanks a lot for your prompy reply.

Showing results for 
Search instead for 
Did you mean: