Forum Discussion

lslechta's avatar
Occasional Contributor
4 years ago

The grid row's index 0 is out of bounds

For some reason I keep getting this error even though the row is actually there.  Any suggestions?  I've tried clicking the field and using the enter key on the field when recording the keyword test. Same thing happens each time.


  • This happens sometimes because of slowness. May be try adding a delay of 3 to 6 seconds before the operation (Where you are selecting the row) and see if that still happens. We have the same issue and we wrote some dynamic wait functions to wait for rows to display/visible.

8 Replies

  • what operation is being performed on that grid row 0 object

    what does it say about that error within the details tab of the error message/step?

    • lslechta's avatar
      Occasional Contributor

      I've tried a double click or just leaving the row highlighted and clicking OK.

      The Details say total number of rows is 0. What would cause that?


      • hkim5's avatar

        try going into the operation parameters of the double click to see if it is relying on the coordinates of the object.

        you can do this by clicking on the value column of that operation, pressing F2 and then clicking on the 3 dots that appear within that value column.

        if you see coordinates for clientx and clienty, then change both values to be -1