Forum Discussion

MHatcherEzp's avatar
New Contributor
3 years ago

TestExec running via Jenkins agent throws a permissions error despite all programs running as admin

I am about at my wits end. I am attempting to use Jenkins to kick off test automation that utilizes TestExecute and I keep getting this error despite literally every file, folder, etc. is set to run in full admin mode. Highlighted the error in RED and bolded the text. I am at a loss right now, NOTHING I do seems to make a diff for that error. I have tried running as a service, tried running TE and everything else with admin privileges, tried using the System user, tried using and Admin user. Nothing seems to be elevated enough for this process on WIN 10. Some context, I am updating our test automation VMs from Win 7 (Does NOT exhibit this error) to Win 10 (DOES exhibit this error).

[TestComplete] The test execution started (MasterTests).
[TestComplete] Found TestComplete/TestExecute installations:
	Type: TE, Version: 15.40.421.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe"
[TestComplete] Selected TestComplete/TestExecute installation:
	Type: TE, Version: 15.40.421.11, Path: "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe"
[TestComplete] [WARNING] The node is connected via Java Web Start (JNLP). In this mode, the "Run interactive user session" property of the TestComplete Test step is ignored. TestComplete (or TestExecute) will work in the current user session.
[TestComplete] Launching the test runner.
$ "C:\Program Files (x86)\SmartBear\TestExecute 15\x64\bin\TestExecute.exe" "c:\jenkins\workspace\test MasterTests\MasterTests.pjs" /run /SilentMode /ForceConversion /ns /exit "/ExportLog:c:\jenkins\workspace\test MasterTests\1265255.tclogx" "/ExportLog:c:\jenkins\workspace\test MasterTests\1265255.htmlx" "/ErrorLog:c:\jenkins\workspace\test MasterTests\1265255.txt" "/ExportLog:c:\jenkins\workspace\test MasterTests\1265255.mht" /DoNotShowLog /ForceConversion /SQL=false /Run
[TestComplete] [ERROR] An exception occurred: CreateProcess error=740, The requested operation requires elevation.
[TestComplete] Marking the build as FAILED.
[TestComplete] [WARNING] Unable to publish test results (xml data is empty).
[TestComplete] The test execution finished (MasterTests).
Build step 'Conditional step (single)' changed build result to FAILURE
Strings match run condition: string 1=[All], string 2=[All]
Run condition [Not] preventing perform for step [TestComplete Test]
Started calculate disk usage of build
Finished Calculation of disk usage of build in 0 seconds
Started calculate disk usage of workspace
Finished Calculation of disk usage of workspace in  3 second
[Office365connector] No webhooks to notify
Finished: FAILURE 

3 Replies

  • Hi MHatcherEzp!


    Were you able to make any progress on this issue?


    I ran into this with a customer a while back and the solution in their case was to install the node as a windows service and allow the OS to launch the node. Though it sounds like you have tried that. 


    I have also seen this with machines using Active Directory for user accounts. For machines using AD, an AD specific credential should be created in Jenkins and passed into the 'Run interactive user session' option found by clicking 'Advanced' button in the TestComplete test plugin in the Build section.


    Jenkins Credential

    Setup within the TC plugin


    Let us know if you have made any progress or if any of the above information may be helpful! 

  • MHatcherEzp's avatar
    New Contributor

    I have made progress on this issue. It had to do with our particular setup and that the Jenkins installer was running TestExecute as the SYSTEM user, preventing some executions of PS scripts we utilize.