Forum Discussion

hhowe's avatar
Occasional Contributor
8 years ago

TestComplete window repositions / moves every time I "show in object browser"

Far from critical, but still maddening. I have my TC window positioned exactly where I want it, and not maximized (although this happens when maximized as well). Every time I choose the "Show in Object Browser" item from the Name Mapping context menu, the entire TC application window is repositioned to (roughly) center of my screen. This both moves the title bar and changes the size of the window. Not at ALL where I want it.


I've reviewed the Tools > Options as well as the Project properties (and searched the forum) and find nothing to address this. Anyone know of a setting to prevent this?


Many thanks,


  • Rolled back to using an image I had with 12.20 (and an old copy of the TC project). Did not have the focus issue. Updated to 12.30, no repositioning issue. Restored the current copy of the project, no repositioning issue. I am currently in a good state without this issue (but wonder what else I may have lost in the rollback!). We'll find out.


    If this issue recurs, I will post here again, and try to pay more attention to what changes may have been applied that could affect it.

4 Replies

  • tristaanogre's avatar
    Esteemed Contributor

    Interesting... do you have your object browser docked differently than the defaults?  Because this is not a behavior I've experiened.  I usually have TC maximized but you say it happens even then.


    BTW, as I'm typing this, I tried it in TC 12.20 with a non-maximized TC... and I'm not reproducing.  So, there's something different in your general arrangement that is not typical or you've run across something pretty obscure.

    • hhowe's avatar
      Occasional Contributor

      Obscure and maddening. Yes, I already said maddening, but it bears repeating. I have tried to Restore Default Docking as well as custom docking arrangements to no avail. I should mention I'm on 12.30.

      • hhowe's avatar
        Occasional Contributor

        This is a new machine for me, and wasn't using it enough on 12.20 before I upgraded to know/recall if I had the issue with 12.20 doing this. I think I will return to 12.20 to see if it resolves the matter. I'll update here once I do this test. Thanks for your feedback.