Forum Discussion

kitaitoa's avatar
kitaitoa
Contributor
2 years ago

TestComplete error on event click button

Hi there,
Background: I am using the Smartbear web project sample to test an azur devops pipeline and run it in a Scale Set Virtual Machine (VMSS). (It uses testExecute)
https://support.smartbear.com/testcomplete/docs/tutorials/samples/web/index.html

 

The test does not have the same result when I run it locally in my computer or on the VMSS.
Indeed, on the VMSS, while it has just been provisioned, the submit button click event does not react, and an error is detected because the next page does not open.
On the second run with the same VMSS (it has already started), no error occurred  !
Locally, on my computer, with TestComplete, I never have any error.


Similarly, if I create an Azure VM with testComplete and testExecute and use it in my pipeline, I never get an error either.
(yaml file "sample_demo_VM_VMSS.yml.txt" attached to see the differences)

 

I tried to do some tests and modify the TestComplete script to understand this problem:
- tested the state of the button enabled or not, but it is also "ENABLED". so the button 

 

if (panel.submitbutton.enabled)
  {
    Log.AppendFolder("submitbutton=ENABLED");
  }
  else
    Log.AppendFolder("submitbutton=DISABLED");  

 

=> So the button exist and it found in the page

 

- I added a loop to click on the button until the following page appears:
after 2 clicks the following page opens! ! !

 

bt=Aliases.browser.page.Aspnetform.panel.submitbutton
bt.ClickButton()
bt.Click()
bt.Click(10,20)
iclick=0 ;
while (!page.Aspnetform.table.Exists || (!page.Aspnetform.table.Exists && iclick <11))
{
iclick++ ;
Log.AppendFolder("click="+iclick) ;
panel.submitbutton.ClickButton() ;
}

 

=> But this solution is not functional in time, we can't add loops in our projects!!!

 

- I updated the project parameters, 
https://support.smartbear.com/testcomplete/docs/working-with/managing-projects/properties/playback.html#:~:text=Auto-wait%20timeout%20is%20the,allowed%2C%20the%20test%20proceed%20immediately.
* Automatic timeout = 60,000 or more
* Use case sensitive parameters = true
* Delay between events = 60,000

=> But without finding a solution

 

Can you help me understand this problem ?

 

Thanks