Forum Discussion

peejay1977's avatar
Occasional Contributor
4 years ago

Object recoginition completely failing

Hi all,


It's been a while since I've used TestComplete and our maintenance subscription has lapsed. I have an urgent need to fire it up and rerun some tests I wrote a while back but for some reason the software is refusing to see Firefox as a browser. It'll find and interact with Chrome but will open Firefox but then says Sys.Browser cannot be found.


I have completely reinstalled TestComplete 14 and let it update the Firefox and Chrome modules but to no avail. What I did notice is that if I attempt to map a new object using the point and click approach, it only selects/highlights the entire window in red. Nothing inside it. I tried this on both Firefox and Chrome.


I then thought it might be due to me accessing this installiation over RDP. So I've installed it locally and have exactly the same issue, it will not select any objects on screen at all.


Am I missing something really obvious?


Many Thanks!


4 Replies

    • peejay1977's avatar
      Occasional Contributor

      Version 77 but I tried downgrading to 76 and same issue.


      Only thing I didn't have was the Environment Variable which I hadn't needed in the past but this has made no difference unfortunately. If I try to highlight any object I just get the Window and none of the inner objects get highlighted.


      I've not even got to the point of running the tests yet. I can get TestComplete to open Firefox but it doesn't navigate to the URL specified. If I change that line to alter btFirefox to btChrome it opens Chrome and navigates to the URL. But I cannot pick an object using the Name Mapping Add Object picker in any browser.


      If I simply have a test that tells an instance of firefox to open, then on the next line asks it to navigate, it opens Firefox but then the navigation fails and I get this.