Forum Discussion

endorium's avatar
Frequent Contributor
2 years ago

Issue with permissions and azure pipelines

So I am setting up pipelines to run testcomplete tests. Source control is setup as GIT in testcomplete.

Agent configured but when I run the pipeline I get the below:


Starting test execution, please wait...
Failed to get a list of tests from the "C:\Agent\_work\1\s\AutomatedTests\AutomatedTests.pjs" file due to the following error: Unable to connect to TestComplete: The requested operation requires elevation. (Exception from HRESULT: 0x800702E4)
No test is available in C:\Agent\_work\1\s\AutomatedTests\AutomatedTests.pjs. Make sure that test discoverer & executors are registered and platform & framework version settings are appropriate and try again.
Results File: C:\Agent\_work\1\s\TestResults\snejad_W-TE-014_2022-11-15_11_36_41.trx
Any help on this? I have tried disabling the windows store option. 
Also tried adding uiAccess="true" to the testcomplete manifest file on the agent machine but to no avail. Cannot work this out so help is really appreciated.



3 Replies