Forum Discussion

KeyEmBen's avatar
KeyEmBen
New Contributor
9 days ago

How to setup Edge TestComplete Extension settings in script?

I am running tests from Azure Pipeline. This pipeline is preparing required Win11 Virtual Machines and then it starts Test Plans using Test Execute. Several test plans requires to open local html files, but this can be done only if in TC Extension we enable "Allow access to file URLs".

I have created test case which is enabling this option, but unfortunately this works only when I run Test plan manually in TestComplete. When I use Azure Pipeline to start this full testing, it is always failing in very beginning to find Details button inside Installed extensions page. 

  • First, in order to see Edge Settings page Objects I have enabled to accept any window in Current Project Properties(Found this suggestion in this forum)
    And only then I was able to see all objects from Edge settings page in Object Browser,
    but Object Spy still does not recognize any object and shows only the main page info.
  • In test itself, I am opening extensions webpage and checking if its Object Type is Form. This way I hope that all mapped objects of this Form will be initialized.
  • Then I am setting a variable with direct path till this Details button and it worked, but only on manual test, failed in Azure pipeline.
    Then I have mapped this Details button and all its parental objects. Used this Mapped Objects path and it worked on manual run, but again failing when i run same test in Azure Pipeline.

    Variables for this button
    If condition to check if this button is visible on each variable.
    On Manual run I am getting success
    when in azure Pipeline with new fresh VM it failed
    reported error about failing to find button Details object property

I have made many tests and various additional actions to refresh Object browser, refresh mapping, added various delays and checks, but nothing is helping and each time it fails on Azure pipeline. The difference is that in Azure Pipeline it is always creating new virtual machines, installing all required software and then starting Test plans. So each time it is new fresh test environment and new first start for Test Execute. I assume this new fresh start is the cause of it and it fails because everything is empty.

Any suggestion how I could get those Edge extensions page objects initialized in very start of testing?

It seems that those, somehow are not active or does not exist and then mapping does not work.

Thank you all in advance.

3 Replies

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    TestExecute should automatically install SmartBear Test Extension (can also be installed separately)

    You might have group/policy settings enabled, that are preventing certain access, or it could be the actual browser disabling the options.

  • KeyEmBen's avatar
    KeyEmBen
    New Contributor

    Test Extension is installed and available in Edge, the issue is with those objects inside this page, which I have mapped.
    The main problem which I posted with all info is that I can't get it working when I run Test plan from Azure Pipeline on new Win11 VM
    When I log in to same VM and when I open Edge Extensions page, then I can highlight mapped Details button and mapping works then. Of course in very start it takes some time to find it. I assume it does some scanning or initialization of all items in Object Browser.

    I am missing something with this process. Maybe there is some other method or way how to initialize and make all those objects available when we start Test? I did saw one discussion about web page objects which should be selected first and only then they can be found but in my case I am trying to select that Details button, but it reports that such object does not exist. How I should select it then?