Forum Discussion

mrajendran's avatar
mrajendran
New Contributor
9 months ago
Solved

French notations are ignored when entering data in a text field

Test data (French text - Indésiré) using SetText method or Keys inputs only the English letters (Indsir).
That is, When entering data in a text field, the text is typed without the letter that has French notations (Say é).

Ex: Indésiré --> Indsir
  • There was a need of the settings update as below

    # Settings -> Time & Language -> Language -> Administrative language settings -> Change system locale button under Administrative Tab -> "Current system locale" as French (France)
    # -> which will get reflected in "Settings -> Time & Language -> Language" as "Français (France) Language pack installed" under "Preferred Language"

7 Replies

  • mrajendran's avatar
    mrajendran
    New Contributor

    There was a need of the settings update as below

    # Settings -> Time & Language -> Language -> Administrative language settings -> Change system locale button under Administrative Tab -> "Current system locale" as French (France)
    # -> which will get reflected in "Settings -> Time & Language -> Language" as "Français (France) Language pack installed" under "Preferred Language"

  • eykxas's avatar
    eykxas
    Regular Contributor

    I have all the settings configured properly, but I get the same problem. Some diacritic are ignored. (like circumflex accent for example).

     

    For instance : é and è are typed properly by TC but all of these letters > ä â à ë ê ì  ò ö ô, are ignored.

     

    EDIT : after some investigations, the issue occur with "Sys.Keys" function. If I use the property Text of my textbox ( object.Text = value) all the letters with diacritics work. But in the case of my webapp, I can't use this method. My textbox need a real input to work properly.

    EDIT 2 : I found a workaround. If I use low level procedures and write : "B^atiment" instead of "Bâtiment" it works.

    • mrajendran's avatar
      mrajendran
      New Contributor

      Thanks for the reply rraghvani 

      But the French alphabets are still ignored. Please refer the below image.

       

       

      did you install any extensions to support this?

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    I'm using TC v15.55.53.7 on Windows v10.0.19045 using the following,

     

    Also, ensure your system font supports other characters.

  • rraghvani's avatar
    rraghvani
    Champion Level 3

    Are you able to use object.Keys("[Alt0226]"). For example,

    In the documentation, it does mention you can use X and D tags for circumflex characters - I couldn't get this to work though.

     

    Use Character Map, to get the correct code.

     

  • eykxas's avatar
    eykxas
    Regular Contributor

    its not working. If I use [D221]a it gave me a regular "a" without the circumflex.

     

    EDIT : okay ! So I have three syntax possible (for the word Bâtiment) :

     

     - B^^atiment > works with Sys.Keys natively

     - B^atiment > my own solution

     - B[Alt+0226]timent > works with Sys.Keys too.