Forum Discussion

JennyH11's avatar
Frequent Contributor
6 years ago

Error on trying to run property checkpoint on an object in kwtests



I'm getting an error when a kwtest is checking a property of an object. The error is "You are trying to call the "cell" method or property of the following name mapping object:..." - see attached for full detail.



I've had a read of this link (


....and have followed the detail in the remark etc but it's still not finding the object. As the article only gives detail on resolving in a script I've used my own knowledge and thinking on how to resolve in a kwtest. I've tried using Call Object Method to obtain the reference to the underlying test object - see attached for screenshot of how I've implemented it.


When I run the Call Object Method on that object (....tableGridswapsmasterDxmaintable.cell) I get "Invalid number of arguments" and the same detail in Additional Info. It's like I'm missing something...



What am I doing something wrong?


Any advice is much appreciated, thanks!


  • We've run into this problem.


    Take a look at your mapping.  There is a mapped object of tableGridswapsmasterDxmaintable.cell.  This is intereferering with the Cell (note the case) method of the table object itself.  Rename the lowercase "cell" to something else and try again.  We usually name our individual cells (if we need to) using the row and column like cell12 for a cell with row 1 column 2.


    This should resolve your problem.

3 Replies