Forum Discussion

allenj2020's avatar
8 years ago

Distributed host, Verification Failed: Communication Error even in Manual mode

I have a large existing test project, but am just starting to try to split it between multiple computers.

I created a master project in the suite, added NetworkSuite to master and slave, and added a Host computer.

I already have a RDP session open to this (physical) computer, which has TestExecute, and have run tests on it in the past by accessing the suite via a network location.  

But in Hosts panel, whenever I try to Verify, even in Manual mode, I always get Verification Failed with Communication Error.

I've tried using a separate login (on the same domain) and my own login.

Windows Firewall is off, and I even disabled the antivirus on the host computer, no change.  I can see and pick the host from the Address list.

I've tried various combinations of Shared and Base path values, both local to the host and shared, with no luck, and read through the 'Verification Failed' help pages multiple times.  

TestComplete 11 Service is running on the host.

I've attached screenshots of my NetworkSuite and Hosts setup.  


Any ideas?  If I can get just the most basic setup to verify even once, hopefully I can start working my way up from there.







  • allenj2020's avatar
    8 years ago

    Update: A short support call determined that the ports were the problem.

    After changing the ports on the remote machine with TestExecute from 1,2,3 to 6090,6091,6092 (same as the master machine), the remote machine verified successfully, with no changes to paths.

    The rep said that they have seen this happen sometimes where the ports get set incorrectly by default, they haven't been able to reproduce the cause of it.

    Also on the host machine, in Allow Remote Access, he had me uncheck 'Allow connections only from computers running Remote Desktop with Network Level Authentication', although I don't think this was the cause of the problem.




8 Replies

  • Do you have the firewall and antivirus off on *both* the master and slave?  Is TestComplete 11 Service running on both?  Are both machines using the same set of Network Suite ports?  Are both machines on the same subnet?  If not, are you sure that the Network Suite ports are not blocked?


    Try addressing the machines by IP address.  Does that work?

    If using machine names, try using nslookup to check that the IP addresses of both machines match when queried from the master and the slave.

    If trying to use a domain account, try instead creating a machine-local account and using that (domain should be the machine name).


    And also recheck the suggestions here:


    Verifying Tasks, Jobs, Hosts and Network Suites

    • allenj2020's avatar

      No luck so far, I have checked the following:


      Firewall and antivirus off on both master and slave - check
      TestComplete 11 service running on both - check
      Both machines on same subnet, or if not, Network Suite ports not blocked - check.  I also verified that I can telnet to the remote machine IP address with port 6090
      Try addressing machines by IP address - check
      Use nslookup to check that IP addresses of both machines match when queried from master and slave - check
      Try creating machine-local account and using that - check
      Recheck suggestions under: - check
      I tried launching my local TestComplete as admin, no change
      Every other network connection I have tried to the remote machine, whether ping, telnet, or RDP, with local or domain users, all work fine.  Yet TestComplete refuses to verify it as a remote host, it's always the 'Communication error'.
      I feel like I'm missing something basic but I can't figure out what.
      Both machines using same set of Network Suite ports (all set to default 6090-6092 range, no changes) - checked OK on local machine.  Host is running TestExecute,  When I opened the host/child project in TestExecute and selected the Network Suite menu under Engines, TestExecute locked up completely and I had to kill the process.  It refused to restart TestExecute until I restarted the PC.
      After restarting the host PC, I opened the Project Suite in TestExecute (not the project) and rechecked Network Suite settings.  It says TCP ports for remote connects are 1, 2 and 3?  Is that right?  I opened the project and checked and it says the same.


      • allenj2020's avatar

        Quick update: After playing around with settings some more it has now morphed into a 'Server not started' error.

        I've opened a support request.  If I get a solution I'll post it here.