Forum Discussion

bgabriel's avatar
bgabriel
Occasional Contributor
5 months ago

Can't access GridControl NewRowCell

Hi,

I'm trying to test my .NET 4.6.2 WPF application developed with Devexpress 21.2.4. I need to populate a Devexpress GridControl component with data to verify the functionality. 

When I'm trying to access the grid's new row using the appropriate methods (TC support: Devexpress under Action paragraph), it can never be found. I've tried several methods such as 

  • ClickNewRowIndicator
  • ClickNewRowCell
  • HoverMouseNewRowCell
  • ...

Nothing is working here, I'm always reaching the timeout

I'm wondering what defines a NewRow in the TestComplete environment. 

To be sure that the problem is not related to my application specifically, I tried to use the devexpress demo center tool to test those methods on another gridControl instance: same result... I added a screenshot of the demo center in the attachment for you to visualize the newRow I was targeting.

Even when using the record functionality of TC, the test can never be repeated because the clicks on the newRow are translated into clicks on the ColumnHeader.

I've read several documentation articles on the TestComplete support center without finding the proper example. 

TC Version: 15.59.7.7 x64

I really appreciate any help you can provide.

 

3 Replies