Forum Discussion

manojgholawade's avatar
manojgholawade
New Contributor
5 years ago

After update to TC14 objects are taking longer to reflect in object browser

Hi,

 

I had the test framework for AUT and it was working fine on TC12 without any errors.

Last week I have updated to TC14 and I observed lag in identifying objects in object browser.

Tests which were running without any errors on TC12 are getting errors now.

It is observed specially for dialogs and popups it is taking longer than usual (compare to TC12) to create object in object browser due to which it could not detect object and tests are failing.

It can be seen in attachment that popup is visible on screen and even name mapping for it is also correct but since it is takes time to reflect in object browser it fail

I would really appreciate any help on this.

Thank you very much in advance!

 

Regards,

Manoj

 

  • sonya_m's avatar
    sonya_m
    5 years ago

    Thank you hkim5.

    manojgholawade , was it solved for you?

    If you are still experience this, what you might want to do is open a ticket with the Support Team to investigate this deeper. 

    After you get the investigation going, please update us on the solution from the Support Team:smileyhappy:

3 Replies

  • I'm not certain how exactly the dialogue would have been detected in TC12, but those types of pop up dialogues may be getting detected as an unexpected window in TC14, which may cause TC to ignore those windows, leading to some problems in detecting the objects.

    if you go into tools>current project properties>playback

    you could perhaps try tinkering with the  on unexpected window checkboxes (namely by turning off the send close command and press esc) and see if you have any better luck with TC interacting with the popup dialogue

    Lastly, it depends what that dialogue is exactly. If it is a microsoft windows based pop up dialogue, you may need to enable MSAA * support to interact with those yes or no options (say like download a file dialogue)

    Keep us updated on any progress :)

    • manojgholawade's avatar
      manojgholawade
      New Contributor

      Hi Justin,

       

      Thank you for your prompt response.

       

      Actually, I have already mapped this dialogs and as per test specs it is expected to come this dialog and already wrote a test complete script to handle such dialogs.

      It is not unexpected window because I can see mapped name when I use Object Spy on it.

      The issue is initially for TC12 it was running without any delay but now after update it just shows "Waiting for object recognition" and takes much longer. If before waitaliaschild timeout it couldn't detect an object then test fails which use to pass in TC12.

      If I increase the timeout then it works but, I don't understand why it has become sluggish after update.

      Is there any specific setting I missed after update?

      Also, MSAA* support is already enabled.

      • sonya_m's avatar
        sonya_m
        SmartBear Alumni (Retired)

        Thank you hkim5.

        manojgholawade , was it solved for you?

        If you are still experience this, what you might want to do is open a ticket with the Support Team to investigate this deeper. 

        After you get the investigation going, please update us on the solution from the Support Team:smileyhappy: