Forum Discussion

dynmo1's avatar
dynmo1
New Contributor
7 years ago

SoapPro 4.6.2 Environment handling

How do I fix environment handling feature in soappro 4.6.2? Previously I was able to use the dropdown box to switch environment for REST test, and now I have to select default and change each environment individually. If I select the example stage environment my endpoint are blank. This worked perfect for last several years and then around March 2017 stop working as previously. Seem like my Environment switching is out of sync. This is the feature https://www.soapui.org/soapui-projects/environment-handling.html

6 Replies

  • Debz's avatar
    Debz
    Contributor

    Hi, I'm not sure if you can still get support for your version. From what my team experienced this year, the environment selection feature is now only available for SoapUI NG Pro and not available on SoapUI Open Source. 

    • dynmo1's avatar
      dynmo1
      New Contributor

      This is not open source version, the company has paid good money for license for everybody using 4.6.2. 

      How can smartbear take something away that was previously working under that versions?

      I can't update to the version 5.1.2 due to project I'm in middle of and api call that we also have a license & based up a few colleague they are having same issue. Urgg

      • Debz's avatar
        Debz
        Contributor

        Hi,

         

        I'm not sure how licensing works during the time you purchased 4.6.2 but as far as I know, paid application customers are entitled to product support. Maybe they can confirm if the environment selection should not have been affected by the recent product change to two separate applications: SoapUI Pro and Ready!API 2.0 with SoapUI NG tab or if there are other factors on your project that could have caused some part of your environment selection to break. Try dropping a message to the Smart Bear Customer Support. If there's someone who can confirm the change from your version to the new one, I think it's the guys out there.

         

        I have only worked with the 5 point something versions last quarter 2016. The available licences during the time I started working with SoapUI are the free (5.3 Open Source) and annual subscription based (Ready!API 1.8 onwards) but when I talked to a Customer Service representative and lead, they told me if I bought a subscription for more than a year, they can provide me with a discount. Maybe they can assist you with transitioning to the new product. I've asked my client to update from Ready!API 1.8 - 2.0. I told them 2.0 have better report and UI. The upgrade was free since their subscription year is still on even if the product version is different.

  • nmrao's avatar
    nmrao
    Champion Level 3

    SoapUI Pro is no more active and it is transitioned to new product called ReadyAPI. Even this product version now is 1.9.0 and about to release 2.0.
    There are lot many features being part of this new product. Suggest you to move to this latest software if possible for you and that can possibly resolve the issue that you are currently experiencing.

    Of course, you may install ReadyAPI along with your current installation, I believe.

    All you need to care is to have a backup of your project before using them in ReadyAPI (in case you start using it) as the project xml might not be compatible with previous software versions / editions once project is saved in later version.