Forum Discussion

ssirapu's avatar
ssirapu
Occasional Contributor
4 years ago
Solved

ReadyAPI-x64-3.2.0 does not launch in WIN10 64

Hello friends,

 

First time installation of ReadyAPI-x64-3.2.0 does not launch or Failed to start ReadyAPI in WIN10 64 

 

I've gone through existing solutions but didn't match to my issue. 

 

There is no C:\Users\<UserName>\soapui-settings.xml file to update connection settings.

There is no C:\Users\<UserName>\soapui-workspace.xml file to delete

There are three files postgresql-9.3-1102.jdbc41.jar, sqljdbc42.jar and readme.txt only in

C:\SmartBear\ReadyAPI-3.2.0\bin\ext

 

could you please direct me to right solution.

 

Thanks,

Srini

 

 

 

 

 

  • Hi ssirapu,

    The fact you say when you tried installing v3.1.0 and got the same behaviour as when you installed v3.2.0 is indicative that theres some environmental clash on your laptop.....i.e. ReadyAPI! showing no visible boot up.

    I did mention this in my last but i dont think i was clear. When you try and launch ReadyAPI!, if you launch taskmanager (not taskbar), and select the processes tab, does an entry appear equating to ReadyAPI!? Im just wondering that 1. Do you get a ReadyAPI! instance appearing in taskmanager and 2. If there is anything maxing out the resource usage on your laptop. I know pre_fetch on win10 can bring disk usage up to 100% for maybe 10/15mins after boot (along with swap file usage) depending on your setup (especially if youre running an I5 processor) and so if ReadyAPI! startup is sequenced after other stuff thats maxing out your resource usage, it could take a long time to start....perhaps even 20mins (i once had a ReadyAPI! instance on a rubbish VM that took 20mins to boot), but it might still start. So wondering when you say its not starting is it just that it'll take a long time to start but still might.
    Whats the spec of your laptop? RAM? processor?

    Is the java run time (jdk not jre as i remember i think some groovy needs libraries available only in the jdk not the jre) you have installed 64bit as well? It is essential that the 'bit type' (sorry...dont know the correct term for this) either 64bit or x86 (32bit) of your installed java instance is the same bit type as your ReadyAPI! instance. I thought that Smartbear still made 32bit ReadyAPI! but from the page Rao supplied it doesnt appear so anymore, so just make sure your java is 64bit as well.

    Finally if reinstalling hasnt helped, and the other stuff i mentioned doesnt help, id raise a support call to Smartbear (i cant provide the link cos im typing this on my phone, but the support link is at the top of the forum page) .

    Hope the comments my have helped,

    Rich

11 Replies

  • richie's avatar
    richie
    Community Hero
    Hi ssirapu,

    Just wondering. Did you do an upgrade (upgrade an existing version and the same program files directory) or did you do a fresh install? (I always do a fresh install when upgrading)

    Ive just installed v3.2.0 without any problems on my Win10 64 it laptop. I was previously running v3.1.0

    I have the soapui-settings.xml file and default-soapui-workspace.xml files in C://Users/Rich directory. Those 3 files (the 2 .jars and the .txt) were successfully created in bin/ext directory in the program files directory too.

    Id double check if the .xml files (settings and workspace) are definitely not present or not.....the files arent hidden (beginning with a period/fullstop) so they should definitely be displayed whatever the file/folder view permissions are set (unless you dont have local admin or its a networked laptop and Group Policy is hindering viewing your profile), but i'm wondering if youre just not seeing them because perhaps your windows file/folder view permissions arent displaying extensions including type .xml???

    Have you noticed when you attempt to launch ReadyAPI! ehat happens in taskmanager.... do you get a ReadyAPI! entry in taskmanager when you try and launch?

    At this point, whatever your answers are to my above questions i think id try and reinstall v3.2.0 to the same directory and go from there.

    Cheers,

    Rich
    • ssirapu's avatar
      ssirapu
      Occasional Contributor

      Hi Rich,

      Thanks for the prompt response.

      1. Its not an upgrade, I've same issue with both versions ReadyAPI-x64-3.1 and ReadyAPI-x64-3.2

      2. Nothing appear in Taskbar related to ReadyAPI 

      3. soapui-settings.xml and default-soapui-workspace.xml files are not available, I cross checked  after enable show hidden files and extensions.

      4 I've local admin rights to install and to change folder permissions.

       

      One thing I noticed, If I click on batch file ‪C:\SmartBear\ReadyAPI-3.2.0\bin\ready-api.bat, then launches but no use because nothing save ( projects including licence key info) after reopen through batch file.

       

      any other clues, please advise?

      Thanks,

      Srini

       

       

  • nmrao's avatar
    nmrao
    Champion Level 3
    Which installer file are you using to install?
      • richie's avatar
        richie
        Community Hero
        Hi ssirapu,

        The fact you say when you tried installing v3.1.0 and got the same behaviour as when you installed v3.2.0 is indicative that theres some environmental clash on your laptop.....i.e. ReadyAPI! showing no visible boot up.

        I did mention this in my last but i dont think i was clear. When you try and launch ReadyAPI!, if you launch taskmanager (not taskbar), and select the processes tab, does an entry appear equating to ReadyAPI!? Im just wondering that 1. Do you get a ReadyAPI! instance appearing in taskmanager and 2. If there is anything maxing out the resource usage on your laptop. I know pre_fetch on win10 can bring disk usage up to 100% for maybe 10/15mins after boot (along with swap file usage) depending on your setup (especially if youre running an I5 processor) and so if ReadyAPI! startup is sequenced after other stuff thats maxing out your resource usage, it could take a long time to start....perhaps even 20mins (i once had a ReadyAPI! instance on a rubbish VM that took 20mins to boot), but it might still start. So wondering when you say its not starting is it just that it'll take a long time to start but still might.
        Whats the spec of your laptop? RAM? processor?

        Is the java run time (jdk not jre as i remember i think some groovy needs libraries available only in the jdk not the jre) you have installed 64bit as well? It is essential that the 'bit type' (sorry...dont know the correct term for this) either 64bit or x86 (32bit) of your installed java instance is the same bit type as your ReadyAPI! instance. I thought that Smartbear still made 32bit ReadyAPI! but from the page Rao supplied it doesnt appear so anymore, so just make sure your java is 64bit as well.

        Finally if reinstalling hasnt helped, and the other stuff i mentioned doesnt help, id raise a support call to Smartbear (i cant provide the link cos im typing this on my phone, but the support link is at the top of the forum page) .

        Hope the comments my have helped,

        Rich