Forum Discussion

Annie_Murphy's avatar
Occasional Contributor
5 months ago

Invalid User Name and/or Password



After upgrading to 3.47 I was receiving an authorization error message, so I uninstalled 3.47 and went back to 3.44. Now 3.44 is receiving the same error message. So I upgraded to 3.49 and am still seeing the same error. I am just wondering if anyone knows of or has a configuration solution that I can use. I am a functional person running the SOAP UI request to test the response values received. I am logging into Smart Bear as myself and use test users to access the test environment.

This was working fine until 3.47 and now it seems 3.44 is now broken and even 3.49.

I have no idea of what to look for to figure out what the issue is.

Other workmates can access the test environment using the SOAP UI tools they have installed on their laptops and the same test users I am attempting to use.


<faultstring>invalid username or password</faultstring>

5 Replies

  • Annie_Murphy's avatar
    Occasional Contributor


    When this happened in the summer I reverted back to 3.44, starting this past week 3.44 also started to get the same error. 

    So I upgraded to 3.49 skipping the earlier version that started the error originally.

    Not sure how one determines if they need to upgrade to the newer version but in my case I was trying to fix the authorization issue.

    I am not really sure that telling me not to upgrade is a good solution to my issue but thank you anyway for your response.


  • nmrao's avatar
    Champion Level 3

    Few tips:

    Upgrade the version if and only if absolutely necessary.

    It is important to keep the project and artifacts under some kind of repository / version control system.

  • richie's avatar
    Community Hero

    Hey Annie_Murphy 


    Ok - so considering you said you had no auth issues prior to the upgrade, but once upgraded you started getting invalid logon creds warning and even switching to different versions of ReadyAPI - the auth problems still remain.


    If no changes were made to the auth details on your tests immediately prior to the upgrade, then it's reasonable to infer that something has become corrupted in the cred details for the underlying project.xml file (or composite file).


    As changing the versions of ReadyAPI hasn't reverted your invalid creds change (and it shouldn't have), we can again infer that this has nothing to do with the ReadyAPI version you're running and again, the issue is with the underlying project file(s).


    Can you confirm if your project is saved locally - or are you using a shared project file?

    Can you confirm if your project is saved as a single .xml file or the project saved as a composite (multiple discrete files that make up the project file)?


    Depending on your answers will guide us how to proceed.


    If it's a shared file - and other people using their ReadyAPI instances have no auth problems, but when you open the same shared project file(s) on your ReadyAPI instance and you get auth issues, then this is really weird and I can't see how that could happen.


    As I say above - if you can answer the questions - this will guide us on how to proceed.


    Just as an aside - have you compared the RAW SOAP request content (especially the auth details) of what you are submitting in ReadyAPI compared with the RAW SOAP request content (especially the auth details) that your colleagues are submitting?  We could then see the differences between what you are submitting in ReadyAPI relative to your colleagues which would then indicate how to fix.





    • Annie_Murphy's avatar
      Occasional Contributor


      The project is saved locally and is not shared. I am connecting with my internal help desk as well.

      Question: If the project is saved on a google drive could that be causing the issue?

      • richie's avatar
        Community Hero
        Hey Annie_Murphy,

        Rao was saying this just as a general rule. It's advisable to wait and not grab the latest version as soon as it's available unless it includes a fix you need, cos new versions can have regressions. I tend to sit a couple of releases behind the most recent version because of this reason (in fact the release before the latest people found regressions that were breaking their tests....someone posted about this a number of weeks ago)

        Anyway. Ok, so it's a local project.xml file. Don't see how saving to cloud based storage would make any difference.

        So! You mention that your colleagues are running the same tests successfully on their ReadyAPI instances without getting the invalid creds soap fault, right?

        If they're running the same tests from their local copy of the project (i'm ignoring the question of "why?" at this point), have you tried grabbing a copy of their project.xml file (with working tests) and running those tests in your ReadyAPI instance and seeing what happens?
        Assuming those identical tests work successfully (and i've no reason to think otherwise...the ReadyAPI version shouldn't make any difference), you could open both your existing project and your colleagues in ReadyAPI and clone the working tests into your existing project.

        We have a number of options to try to sort your problem, i'm suggesting the easiest/quickest option for now.