Forum Discussion

DennisWCook's avatar
Occasional Contributor
2 years ago

New Collaborator install fails to load page.

New Collaborator 14.3.14302 install on Ubuntu 22 - Start page fails to load. No errors reported during installation. What did I miss?   Error.log contains the following error ; SEVERE:
  • srinivasraj's avatar
    2 years ago


    Are you able to log in to Collaborator server, if Yes, please follow below steps to share dump file for analysis. Or if not please share snap.


    1. Click the "System" link at the bottom of the page (you might have to be an administrator to see that).
    2. In the "Server Backup/Debugging Dump" box at the top of the page, select the following settings:
    a. "Server Logs" => "Include Server Logs"
    b. "File Contents" => "No file content"
    c. "Which Data" => "System configuration only - no review data"
    Then click on the "Download Dump File" button. Send me the resulting zip file.

  • srinivasraj's avatar
    2 years ago

    Hi, I noticed RTC service plugins and their dependencies are caught in the log, i.e. when Collaborator is installed since you selected it during the installation steps and which is not required (hope this is the window - pic attached).


    The logs you see there, are looking for the RTC configuration inside Collaborator server which is not available in Collaborator.


    Please choose RTC only if you're using it in Collaborator server or else you can uncheck the RTC service and install Collaborator, it's works fine.


    If you're using RTC then please use this link to know more about RTC Service in Collaborator.


    Hope this helps.



  • DennisWCook's avatar
    2 years ago
    Thanks - I thought that I had turned off the RTC in this last install attempt. Trying to reduce down to only the basics.

    The current error when attempting to load the page is here;

    May 25, 2023 10:38:28 AM org.apache.catalina.core.StandardWrapperValve invoke
    SEVERE: Servlet.service() for servlet [StartPage] in context with path [] threw exception
    java.lang.IllegalStateException: Cannot call sendRedirect() after the response has been committed
    at org.apache.catalina.connector.ResponseFacade.sendRedirect(
    at com.smartbear.ccollab.CollabCleanupFilter.doFilter(
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(
    at org.apache.catalina.core.StandardWrapperValve.invoke(
    at org.apache.catalina.core.StandardContextValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke(
    at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
    at com.smartbear.ccollab.auth.AuthTicketValve.invoke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke(
    at org.apache.catalina.core.StandardEngineValve.invoke(
    at org.apache.catalina.connector.CoyoteAdapter.service(
    at org.apache.coyote.http11.Http11Processor.service(
    at org.apache.coyote.AbstractProcessorLight.process(
    at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(
    at org.apache.tomcat.util.threads.ThreadPoolExecutor.runWorker(
    at org.apache.tomcat.util.threads.ThreadPoolExecutor$
    at org.apache.tomcat.util.threads.TaskThread$
    at java.base/

    Thanks Again

  • srinivasraj's avatar
    2 years ago

    The log file has lot SQL errors that is the JDBC connection pool error "Could not create connection to database server". 


    Somewhere in the MySQL configuration (Connector/J) is not properly configured or Connector/J is not using the desired version.


    Please check this link for more information on MySQL with Collaborator configuration.


  • DanKirkpatrick's avatar
    12 months ago

    Did you solve this?  If so, how?

    I had same issue with "couldn't create connection to database server".

    For us, using RHEL8 java fips conflicts with selinux fips.   Try turning off fips and try restarting again.


    (Long term solution was to disable just java fips by editing <java_distribution>/<java_version>/conf/security/ and change security.useSystemPropertiesFile=false)