Forum Discussion

kalpana_seagate's avatar
kalpana_seagate
Occasional Contributor
9 years ago
Solved

ccollab admin review set-participants doesn't work if user id is in digits

When the user name contains digits the ccollab set-setparticipants doesn't work, but the same works if user name has only alphabets. see error below,

 

ccollab admin review set-participants 1593 --participant Author=524975
Connecting to server at http://localhost
Connected to Collaborator Enterprise v10.0.10000
Connected as: Kalpana Manoharan (524975)
ERROR: Executing command `ccollab admin review set-participants`:
Errors found:
[ {
"result" : { }
}, {
"result" : { }
}, {
"errors" : [ {
"code" : "InvalidUser",
"message" : "Invalid User 524975"
} ]
} ]


=====================================================================================

 

ccollab admin review set-participants 1593 --participant Author=codereview
Connecting to server at http://localhost
Connected to Collaborator Enterprise v10.0.10000
Connected as: Kalpana Manoharan (524975)
Set 1 assignments

 

Note: The users are LDAP authenticated.

 

Please help in resolving the issue

 

Regards,

Kalpana

 

  • OlegB's avatar
    OlegB
    8 years ago

    Hello kalpana_seagate,

     

    We have reproduced such an issue in our labs and registered a bug in our bug tracking system (COLLAB-1877). So, our R&D team is aware of the problem now and will try to solve it.

     

    In addition, I have found a possible workaround for you: you can use one of the previous GUI client (9.0.x-9.1.x) versions. Here are copies of my tests with the v.9.1.9101 GUI client:

     

    C:\Users\oleg.beriashvili>ccollab admin review set-participants 3 --participant

    Author=admins

    Connecting to Collaborator Server http://127.0.0.1:8080

    Connected as: ---- -- - (admins)

    Loading review ID 3.

    Found Role 'Author'

    Found User 'admins'

    Resolved participant assignment 'Author'='---- -- -'

    Set 1 participants

     

    And I also checked your previous problem with the "ccollab login" command and it works too:

     

    C:\Users\oleg.beriashvili>ccollab login http://127.0.0.1:8080 admins password

    Trying to login with new configuration

    Connecting to Collaborator Server http://127.0.0.1:8080

    Connected as: ---- -- - (admins)

     

    New configuration worked - saving configuration settings

    Configuration key 'url' saved.

    Configuration key 'user' saved.

    Configuration key 'server-proxy-host' cleared.

    Configuration key 'server-proxy-port' cleared..

     

    Please download the one of these versions of the GUI client using the link below and check how it works:

    https://support.smartbear.com/downloads/collaborator/all-installers/

5 Replies

  • kalpana_seagate's avatar
    kalpana_seagate
    Occasional Contributor

    Any updates? I may have to revert to local database authentication from LDAP if there is no fix for this

    • OlegB's avatar
      OlegB
      SmartBear Alumni (Retired)

      Hello kalpana_seagate,

       

      We have reproduced such an issue in our labs and registered a bug in our bug tracking system (COLLAB-1877). So, our R&D team is aware of the problem now and will try to solve it.

       

      In addition, I have found a possible workaround for you: you can use one of the previous GUI client (9.0.x-9.1.x) versions. Here are copies of my tests with the v.9.1.9101 GUI client:

       

      C:\Users\oleg.beriashvili>ccollab admin review set-participants 3 --participant

      Author=admins

      Connecting to Collaborator Server http://127.0.0.1:8080

      Connected as: ---- -- - (admins)

      Loading review ID 3.

      Found Role 'Author'

      Found User 'admins'

      Resolved participant assignment 'Author'='---- -- -'

      Set 1 participants

       

      And I also checked your previous problem with the "ccollab login" command and it works too:

       

      C:\Users\oleg.beriashvili>ccollab login http://127.0.0.1:8080 admins password

      Trying to login with new configuration

      Connecting to Collaborator Server http://127.0.0.1:8080

      Connected as: ---- -- - (admins)

       

      New configuration worked - saving configuration settings

      Configuration key 'url' saved.

      Configuration key 'user' saved.

      Configuration key 'server-proxy-host' cleared.

      Configuration key 'server-proxy-port' cleared..

       

      Please download the one of these versions of the GUI client using the link below and check how it works:

      https://support.smartbear.com/downloads/collaborator/all-installers/

      • kalpana_seagate's avatar
        kalpana_seagate
        Occasional Contributor

        I'm on version 10 and both client and server are installed on the same machine. Should i roll back both my server and client to older version?