Forum Discussion

joaocorreia's avatar
2 years ago

SOAP UI Plugin Development


I'm in an road to develop a plugin to improve my performance using the SOAPUI. So I start to follow the following official tutorial (, but it seems outdated.

In the current version of maven (3.8.5), it is not possible anymore to specify the repository as commandline argument (for consistency and security reasons) (Ref:


So to suprass the first stone in the road, I run the following command as sugested in github issue:



mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeGroupId=com.smartbear.maven.archetypes -DarchetypeArtifactId=soapui-plugin-archetype -DarchetypeCatalog=



Now the maven stopped complaining about the "archetypeCatalog ... is not supported anymore", but says that the "Specified archetype not found."

Now asks me to choose one artifactId of the big list presented, I tried to find a similar however I can't find anything.

The archetype com.smartbear.maven.archetypes is missing ? Or am I committing a mistake in my assumptions?


Thanks for the help and kind regards,

Joao Correia.

No RepliesBe the first to reply