Forum Discussion

RaghdaMorsy's avatar
Occasional Contributor
6 years ago

Run test from QAComplete failes to click the highlighted object in the correct position

I have a test developed in TestComplete 12.50(64bit)
The test includes a click action, in a web application through FireFox 61.0.1(64bit)
I run the test from QAComplete 11.9 through a VM Windows7(64bit).

When I use UserA in test agent , the test passes fine .
But when I use UserB in test agent , the test reaches the click action, but the click is done in a wrong position , so we don'e get the expected results.

Please check the attached screenshots:
- The passingClick.png image shows the correct highlighting and click of the object.
- The FailingClick.png image shows the click a littel bit above the highlighted object.

I tried to reporduce the issue manually by login the VM with UserB , but I couldn't reproduce it. ( I can click manually and get the exepected results).

Also I tried to change resolution when I login with UserA and run the automated test,but I couldn't reproduce the issue.

It happens only when I run the test from QAComplete , with test agent user UserB.

Can anyone help please ?

3 Replies

  • Nastya_Khovrina's avatar
    SmartBear Alumni (Retired)

    Hi Raghda,

    As far as I can see, you have already resolved the issue in the corresponding Support case. Can you please share the solution with us here?


    • RaghdaMorsy's avatar
      Occasional Contributor

      Hi Anastasia

      Thank you for reminding me , yes it was solved by using scrollIntoView for object we want to click.

      But the original issue was because there were 2 panel over each other , and both panels have an object with the same attributes, I was trying to click the object on the top, while TestComplete was trying to click the object in the back.

      Using scrollIntoView solved the issue, But I still don't know why scrollIntoView worked with the correct object, while click didn't work!
      Also I still don't know why Click was working with UserA , and wasn't working with UserB, then it worked fine when scrollIntoView is used!

      Anyway I'm glad the issue is solved