Forum Discussion

mattwork13579's avatar
New Contributor
4 years ago

Code Collaborator Invalid Port Number

I am using Code collaborator version 8, Ubuntu 20.04, I have open-jdk jre 8 installed.

I am using code collaborator to connect to an svn repository. I am able to connect from my ubuntu machine to the collaborator server in a browser (with the same settings that I am trying in code collaborator), but when using the app. I cannot get past the "Add Files to Review" page, and this error comes up:

Error loging in to Collaborator Server


I/O Error: org.apache.xmlrpc.XmlRpcException: I/O error while communication with HTTP server: invalid port number.

You may need to go to the Collaborator Preferences to fix this problem.


After this message, I went to the preferences page and double-checked my settings, and they are the same as others in my group using the same server, but this message still shows up.

3 Replies

  • OlegB's avatar
    SmartBear Alumni (Retired)

    Hi mattwork13579,


    Are you trying to use the Collaborator GUI client? Try to navigate to the Preferences window again and verify that the Collaborator server URL doesn't have the  ".../ui" path at the end of it.



    • mattwork13579's avatar
      New Contributor

      OlegB Verified, there is no "../ui" at the end of the Server URL. I have tried several server URLs that my teammates suggested for the server such as "HTTP://abcdef:8080" this also works in the browser of the same Ubuntu machine when the /ui is added. I have also tried the direct IP address of the server in the preferences URL such as "HTTP://" which also works in the browser with the added /ui at the end. But I did double-check this first before posting and it was not the problem.

      • mattwork13579's avatar
        New Contributor

        I am trying to use the GUI client, if there is a way to use code collaborator without the gui client (like via cmd line?) for this version I can try that as well, if you have instructions where to find that information.

        Here is my version info: Collaborator 8.0.8003 © 2005-2013 SmartBear Software, Inc.