Forum Discussion

Gimpson's avatar
13 years ago

ccollab addgitdiffs not finding local diffs

I'm trying to create a review from a merge conflict in git.  When I run "git diff", I see a diff of the file in conflict.  (With conflict markers, this is how I intend the file to be created in the review.)



However, when I run "ccollab addgitdiffs new", I receive the following output:




Connecting to CodeCollaborator Server http://codecollaborator.rent.com

Connected as: Ryan Olson (rolson)

Creating new review

New review created: Review #120: "Untitled Review"

Attaching Git Diffs to Review

Checking that you are allowed to upload files to this review.

Querying Git for the diffs

Querying Git for the diffs...

Review #120 deleted.

ERROR: Executing command `ccollab addgitdiffs`:

No differences were found.




Is there anything I can do to actually see what ccollab is running for its diff command?  

1 Reply

  • ebrown_1's avatar
    ebrown_1
    Occasional Contributor
    Ryan,



    Sorry that no one has answered your question yet!  Yes, you can do this by generating a debug log (which we commonly use to debug issues) and examining the output.  Use the --debug option to do this (i.e., ccollab --debug ...).  This creates a ccollab.log file in the current directory.  Just grep it for git and you'll see the commands issued.



    Eric