Forum Discussion

gnorkett's avatar
New Contributor
13 years ago

Cannot complete the review

I'm reviewer for a review and have finished my portion. No comments remain on the review and I cannot see anything else that has to be done to complete the review. The author is faced with the same scenario. The message on screen reads:

Cannot complete the review:

You have already indicated that you are finished with this review. You can still make comments or open defects.

There are no buttons to click.

How does the author finish the review so it can be dismissed?


5 Replies

  • cognot's avatar
    New Contributor

    We've faced this situation occasionnally.

    Either of you just add a comment, this will put the review back in inspection, and you will then be able to complete it.


  • gnorkett's avatar
    New Contributor
    Hi Richard

    Thanks for the feedback. Each of us tried adding a comment but it still didn't fix the problem. Not sure what else we can do.

  • Hannah's avatar
    SmartBear Alumni (Retired)
    Hi Greg,

    Are there any other participants in the review that have not clicked "Finished" yet? Has the author also clicked "Finished?"

    Just from what you described, I think this may be a bug. Would you mind sending in a review dump for us to look at?

    To create a debugging dump of the review, open the review in question, then go to the "System" link at the bottom of the page (depending on administrative settings, you may have to be an administrator to do this).

    In the "Server Backup/Debugging Dump" box at the top of the page, select the following settings:

    "Server Logs" => "Include Server Logs"

    "File Contents" => "Include all file content"

    "Which Data" => "Complete database dump"

    "Restrict to One Review" => "Only data from Review ID xxxx"

    Then click on the "Download Dump File" button, and send the resulting zip file to

  • athomas's avatar
    New Contributor
    I have the same problem. I am using version 7.0.7022.

    Adding comments and then marking them as read does not work.

    I see this in the Eclipse plugin and on the website.

    When I try to use the "Report an Error" link at the bottom of the website, the server hangs until I close the report window (I assume the report doesn't get sent). When I say "hang" I mean, no other user seems to be able to perform any other action while the report is trying to be submitted.

    Other members of my team have had the same problem. The "workaround" is to change the name of the review to "[COMPLETED] <original name>" and then just ignore it in your list of reviews that require your attention. However, this workaround will soon become tedious once we have dozens of reviews that can't be closed cluttering up our dashboard.

    Please let me know anything that I can do to help track down this problem.


  • athomas's avatar
    New Contributor
    For what it is worth, if we play around with the reviewer role we can eventually get the review to close by making the original reviewer an observer, and making the creator of the review the reviewer, and putting someone else as an author.

    It makes a complete mess of the review (ie it looks like someone signed off on code that they created), but it works-ish.

    Still not ideal, and still a major problem for us. Doesn't happen on all reviews, just some. Not sure what differences there are, none that we can discern in any case.

    Let me know if there is anything else that I can do to help track down this issue,