Ask a Question

log reporting an error that I cannot find

SOLVED
pclarke
Occasional Contributor

log reporting an error that I cannot find

I ran my overnight project and the email notification stated an error, but on the checking the actual log I could not identify the actual error (there is no error on the log, I even clicked go to next error). I re-ran the test that had warnings and have found the individual test that states an error but still cannot actually find the error. attached a screenshot of the log. Has anyone encountered this before, if so what is happening and how can I correct it.

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
leandroaraujoso
Contributor

Re: log reporting an error that I cannot find

I got it this time, to me, It looks like a bug in TesComplete because even though TC has marke the Log entry in the tree with an yellow icon (warning) it says that 1 error was found in the bottom-left corner.

 

But if its not a bug in TC, here are something you may try to debbug the problem:

 

1 - Create a OnLogError Event and put a breakpoint inside of it;

2 - Run the test again to see if you can trap the action that is causing the error.

 

Let me know if that helps.

 

Regards,

 

Leandro de Araújo Souza

View solution in original post

3 REPLIES 3
leandroaraujoso
Contributor

Re: log reporting an error that I cannot find

Hi pclarke,

 

It seems it is just a warning. I think someone has placed something like this in the script:

 

if (something_is_not_equal_What_I_expected)

{

  Log.Warning("Total pax value not as expected");

}.

 

Please double-click the line with the warning symbol, TC will redirect you to do line of code that has generated that warning.

 

Let me know if that helps.

 

Regards,

 

Leandro de Araújo Souza

pclarke
Occasional Contributor

Re: log reporting an error that I cannot find

Sorry I should have made it more clear. The warnings are fine I understand these, it is the actual error that is stated in the information panel under the Log items but as you can see from the screen shot there are no errors listed in the log. If you select go to next on the log and select error it states that no error can be found.

leandroaraujoso
Contributor

Re: log reporting an error that I cannot find

I got it this time, to me, It looks like a bug in TesComplete because even though TC has marke the Log entry in the tree with an yellow icon (warning) it says that 1 error was found in the bottom-left corner.

 

But if its not a bug in TC, here are something you may try to debbug the problem:

 

1 - Create a OnLogError Event and put a breakpoint inside of it;

2 - Run the test again to see if you can trap the action that is causing the error.

 

Let me know if that helps.

 

Regards,

 

Leandro de Araújo Souza

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: