Ask a Question

how to stop a keyword test step

SOLVED
rek32321
Occasional Contributor

how to stop a keyword test step

Hello All, 

I am currently running TestCompelte 14.91.341.7 and all of my current scripts are keyword tests.  Prior to some of the recent updates, I had the ability to basically add a "stop" or a "break' in my keyword test, with what looked like a solid red arrow (almost like a red play button). Simply by clicking in the far left of the testing steps in my script (in the column where the image icons are).  

 

When running my test, when it got to that point it would stop and then I would be able to let it continue after I looked at whatever I needed.  Right now when I try to do the same thing, I get a red circle, but when I run my script, it will not stop at the test step.  It keeps going.  

 

Was this function removed in some of the past updates?  Or has it been moved or is there a new way to achieve this?

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Marsha_R
Community Hero

Re: how to stop a keyword test step

That's a breakpoint

https://support.smartbear.com/testcomplete/docs/testing-with/debugging/breakpoints/using.html

 

When it's just a red circle instead of a filled in circle, it may be that your debug options have been turned off.  Check here:

Marsha_R_0-1629403676959.png

 


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

View solution in original post

3 REPLIES 3
Marsha_R
Community Hero

Re: how to stop a keyword test step

That's a breakpoint

https://support.smartbear.com/testcomplete/docs/testing-with/debugging/breakpoints/using.html

 

When it's just a red circle instead of a filled in circle, it may be that your debug options have been turned off.  Check here:

Marsha_R_0-1629403676959.png

 


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame

View solution in original post

rek32321
Occasional Contributor

Re: how to stop a keyword test step

Hi Marsha, 

 

Thank you so much for the info!  I didn't realize that Debugging was off and that was what was causing what I was seeing.  I just turned it on and my break point is showing up and working exactly the way I remember.

 

Thanks again !

 

Bob Keenan

Marsha_R
Community Hero

Re: how to stop a keyword test step

You're welcome! Lots of us have done that before. 😉

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
cancel
Showing results for 
Search instead for 
Did you mean: