Ask a Question

Using TestExecute is not working consistently

BallerSanta2
Occasional Contributor

Using TestExecute is not working consistently

I currently have built a test execution plan on my laptop, when I run it on my laptop via test complete, it does everything properly, and does not mess up. I have test execute on a virtual machine, with the same settings on the tested software, and further the same resolution, yet test execute is not doing anything that the commands have laid out for it to do. The little commands it does do, are usually small clicks, but on the wrong objects. 

4 REPLIES 4
BallerSanta2
Occasional Contributor

Correction, TestExecute is not the issue, it is just not running properly on the Virtual Machine, I can't think of any explanation, as stated the applications settings are identical, and the resolution is identical. 

 

Are you able to open TestComplete on the virtual machine and run the tests from the UI?  What happens then?


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
BallerSanta2
Occasional Contributor

Since it is a virtual machine, and TestComplete must be node-locked, you can't start it on a virtual machine, but I just now did the suite on a seperate computer with both testcomplete and testexecute and only the virtual machine is not seeming to work. 

For your license, it may need to be node locked, but TestComplete does have floating licenses and those you can run directly on a virtual machine.

https://support.smartbear.com/testcomplete/docs/licensing/how-to/general/using-testcomplete-on-virtu...

 

It is difficult to debug with just TestExecute, but what I might do is take a subset of your main test, including a part that fails on the vm, and see if you can narrow down what test actions are being skipped.  Post them here if you like.

 

 

 

 

 


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
cancel
Showing results for 
Search instead for 
Did you mean: