Ask a Question

Unable to read project variables, because they were created with a later version of TestComplete

New Contributor

Unable to read project variables, because they were created with a later version of TestComplete


Hi All,

I'm a newbie to this group.

We are using TestComplete (2 Desktop Licenses) for Test Automation and Tortoise SVN for Project Versioning.

I need some help in the following topic.

In Feb 2021, we have upgraded the software from TestComplete 12 to TestComplete 14 (both).
After the Software upgrade, in one of our VM (my colleague’s VM) we get the attached error message (Error_1) when opening the TestComplete which is actually related to software Versioning.

By code change, when I commit and my colleague updates, she gets the error message (Erroe_1). We could see the code change, but not the Project Variables at the Project node in the Project Explorer.

We have checked the Project file (xxx.mds) to check for the Project Variable (Error_2). The Project Variable are available in the xxx.mds file, but somehow the Testcomplete could not read/ load them as they are created in the older version of TestComplete (TestComplete 12), which I assumes the problem is at TestComplete and not at the Tortoise SVN.
We tried looking at the internet, but in vain.

So it would be great if someone from Smartbear community could share their experience if they face this problem or can provide suggestions to solve this problem.

Thanks and best regards,
Sridevi V Balaji


Champion Level 3

Now that you've upgraded your versions of TestComplete, you need to make sure that your projects are migrated to the new version properly.


Check the steps here and confirm that you've migrated the older projects this way.

SmartBear Alumni (Retired)

Thanks for the link Marsha!


Hi @Sridevibalaji9! Does this help in your case?

Sonya Mihaljova
Community and Education Specialist

Hello  @Marsha_R@Sony,


Thank you much for your response. I have already upgraded the Project after upgrading the TestComplete from 12 to 14. but still got the Project variables issues. Somehow I again tried to upgrade the Testcomplete version from 14.20 to 14.73 (because my VM had TC 14.73 and my colleagues VM had TC14.20) and it worked now.


Thanks for the help.


Showing results for 
Search instead for 
Did you mean: