Ask a Question

Unable to install TestComplete Trial Version

Occasional Contributor

Unable to install TestComplete Trial Version


 I am using testComplete for the first time to do the POC for one of our client

I have downloaded the trial version of Test Complete Mobile Automation tool 



But getting the error when i try to install. Just after opening the downloaded executable file getting the  error "1152 Error Extracting Test Complete.msi to the temporary location"

 Attached the Error Screenshot.


Please help me with this ASAP.


SmartBear Alumni (Retired)

Hi Prakashsun,


I’ve removed the link from your question as this is a personal link.


As for your question, I suppose that the installation file was corrupted while downloading. I would recommend that you download it one more time by using a special download tool, for example this one. Please let me know how it goes.

Tanya Yatskovskaya
SmartBear Community and Education Manager



Thanks for the quick reply.


I have downloaded the Test complete8  from the http://download.cnet. com.

I was able to install and when i try launching it asks to activate the license.

but even after activating the license successsfully i am getting the pop up to activate the license again when i try to launch testcomplete.


I have attached the screenshots for your reference.


Please let me know if you need more details



SmartBear Alumni (Retired)

Please request the trial on this page:

The latest TestComplete version is v.11. TestComplete 8 doesn't support testing mobile devices (on Android and iOS).

Tanya Yatskovskaya
SmartBear Community and Education Manager

I tried downloading testcomplete from here

but I was getting the error which i mentioned it first comment.
I tried downloading it 2 to 3 times from different machines still faing the same issue;

- Your anti-virus could be interfering with the installation process.  Try turning it off.


- You could have permission problems writing to the TEMP directory.  Check that you can create a file in %TEMP%


- Some companies set a policy preventing execution from the TEMP directory.  In a CMD shell (as Administrator) create your own TEMP directory, set the environment variables, and retry the installation:



C:\> mkdir C:\TEMP
C:\> set TEMP=C:\TEMP
C:\> set TMP=C:\TEMP
C:\> TestCompleteDemo.exe   (or whatever the installation package is called)


Occasional Contributor

I tried all 3 steps you mentioned.

Still getting the same issue..As you mentioned in 3rd step I have created new temp folder and set the environment variables.


When I run the exe getting the errors, Attached the screenshot for the same-Error Extracting.png



In the newly created temp folder i can see some files getting extracted.

Attached the screenshot for the same --Extracted Files in Temp.png


Also If i doubleclick on the TestComplete.msi in the temp folder getting the error--Windows Installer Error.png


Please help me to resolve the issue.





I tried downloading it 2 to 3 times from different machines still faing the same issue;

I agree with Tanya that TestComplete's installer was not downloaded completely. This well may happen if, for example, there is a proxy between the machines you've tried to download from and SmartBear's site - proxy might cache the broken file and did not refresh it.

Have you checked that the size of downloaded file is the same as it was reported while downloading?

  /Alex [Community Hero]
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
Occasional Contributor



Is there any other place that i can get the seup file Or can you please send the zip file of setup to my email


We are actually running out of time, we need to finalise the tool by next week and show the demo of POC to client.


Thanks in Advance 🙂

The only other suggestion I can think of at the moment is to make sure that you've got enough space on the disk.  If that fails please open a support case.

Showing results for 
Search instead for 
Did you mean: