Ask a Question

Unable to initialize script engine - scripts are not running


Unable to initialize script engine - scripts are not running



when i'm trying to run the script routine testcomplete exit witout executing the script and not showing any detials in results log and i tried to debug but its not going the function/break point. Could you please help me how to overcome this issue.


function sampletest()


see the results screens:



Community Hero

Did you try to run this through testExecute?



Wamboo, i tried with TestExecute and again same issue. When i checked with TestComplete whatever the scripts written in C# script or Jscript are failing to run but its running successfully scripts which are written in JavaScript!!

And about my message of 26-03-2020 09:42 AM ?




Un sourire et ça repart

Community Hero

Hello SriniG

I think this is the right time to call the SmartBear support team for help. In my opinion there is nothing more to think about this situation.

Can you write a request to the support team and let us know about the real correct solution to this problem?

They're working really fast and every single my request has been solved correctly.

Hi  ,

I'm sorry i missed this. when check from command line for Cscript, it showing the information as

Microsoft (R) Windows Script Host Version 5.812
Copyright (C) Microsoft Corporation. All rights reserved.

Usage: CScript scriptname.extension [option...] [arguments...]

//B Batch mode: Suppresses script errors and prompts from displaying
//D Enable Active Debugging
//E:engine Use engine for executing script
//H:CScript Changes the default script host to CScript.exe
//H:WScript Changes the default script host to WScript.exe (default)
//I Interactive mode (default, opposite of //B)
//Job:xxxx Execute a WSF job
//Logo Display logo (default)
//Nologo Prevent logo display: No banner will be shown at execution time
//S Save current command line options for this user
//T:nn Time out in seconds: Maximum time a script is permitted to run
//X Execute script in debugger
//U Use Unicode for redirected I/O from the console


Thank you,


Hi Wamboo,


Sure. Submitted resquest to support team. 


Thank you,


SmartBear Alumni (Retired)

Thank you everyone for helping!


@SriniG I see that you started working with Alexandra on this already. Please keep us posted in this thread on the investigation resuls, thank you.

Sonya Mihaljova
Community and Education Specialist

Thank you all for helping me😀

I have tried with all your suggestions and nothing is worked out then we formatted the desktop and reinstalled the TestComplete then script engine started working. We are suspecting that McAfee or Zscaler or Cylance might blocked the TestComplete script engines. Anyways it started working after formatting the desktop.

Showing results for 
Search instead for 
Did you mean: