Ask a Question

TC 14 and TFS 'project node is write-protected'?

Frequent Contributor

TC 14 and TFS 'project node is write-protected'?

I have new copy of TC 14 installed on my local PC.  We are using TFS for source control.  I did a get latest from source control to my local PC and the let TC 14 convert the project suite. There were many read only permmisions issues opening the project suite after the convert and now each time I open the suite I get the following dialog.  Any suggestions?





Frequent Contributor

SmartBear Support has emailed us a patch to TestComplete 14 as a possible solution to this problem. 
This overwrite issue also causes another issue with TFS.  When a  file is overwritten it is not checked out so the server copy is not updated during check in.  Now your local changes are not in sync with this server.  This causes problems when the code is shared to another user/pc through TFS.  I suspect we never encountered this before  because we were setup with local workspaces instead of server workspaces prior to our upgrade of TestComplete and TFS.
From SmartBear suppot,
"The issue is caused by the fact that files have the "write-protected" attribute enabled. The TFVC subsystem needs to write its key to the project file to provide TestComplete with the information that this project is added to TFS.  You need to allow modifying the files when opening the project (click "Yes to All" when you get the message that files are write-protected). 
Perhaps, it will be easier to disable the "write-protected" attribute for the files at all. I suppose you can contact your IT department for this. 
Also, we suggest installing the patch below which fixes some critical issues when working with TFS. Also, the patch should allow editing a project node without the SCC key. "....


We will evaluate these instructions and the patch and post back with our results.
Have a great day all!

SmartBear Alumni (Retired)

Thanks for posting the update, @scot1967 

Tanya Yatskovskaya
SmartBear Community and Education Manager

SmartBear Support was not able to answer the question about why TestComplete is not working with TFS to check out and change the attributes on some files. <Edit>The patch did not resolve the issue.</Edit>  We will be moving things  to Git soon anyway so I have closed the case with them.  My response is below.


We are still not sure why TestComplete is not checking a file out if it needs to modify it.  For instance we are prompted to ‘Save As’, ‘Overwrite’ or cancel the .mds project file in some cases.  I am sure this is because the file is read only and TFS is changing it when the file is checked in.   Even if we manually change the attribute, TFS will mark it read only again the next time it is checked in.  It may have something to do with Local verses Server workspaces but I am not sure.  I asked our admin if this is something I could experiment with but he said we would be moving all test code to Git soon anyway so not to spend the time on it.


You can close my issue but this may be something that could be investigated and documented on your side if you think it is warranted.

Showing results for 
Search instead for 
Did you mean: