Ask a Question

SessionCreator does not invoke my application and does not provide Test Results (TestExecute)


SessionCreator does not invoke my application and does not provide Test Results (TestExecute)



I have created a Powershell Task in Azure DevOps deployment pipeline to run the SessionCreator Utility. Below is the command -:


SessionCreator.exe RunTest /UserName:****-CORP\**** /password:******** /UseActiveSession /ProjectPath:"$(Agent.Releasedirectory)\_INR-TestAutomation\INR_AutomationProjectSuite.pjs" /arg:/PrjVar:inrExeLocation="$(Agent.Releasedirectory)\_INR\INR Binaries\inr.exe"


it does connect to the remote desktop session where we have installed TestExecute and starts running TestExecute, however, it does not invoke my application and after it fails it does not show the any failed results in the "Test" section of the pipeline.


Any help would be appreciated.


Thank you

Champion Level 2

Are you able to run your test with TestExecute from the command line directly?


Does your TestExecute version match your TestComplete version?



Hi Marsha,


Yes, my TestExecute version matches the TestComplete version.


Yes, i am able to run TestExecute from the command line directly.


Below script runs fine and invokes the application however does not give any result in the "Test" section -:


$testexecute= "C:\Program Files (x86)\SmartBear\TestExecute 15\Bin\TestExecute.exe"
$project = "C:\ADOAgent\vsts-agent-win-x64-2.181.2_1\_work\r1\a\_INR-TestAutomation\INR_AutomationProjectSuite.pjs"
$arguments=$project, '/run', '/PrjVar:tnrExeLocation="C:\ADOAgent\vsts-agent-win-x64-2.181.2_1\_work\r1\a\_INR\INR Binaries\Inr.exe"', '/exit', '/DoNotShowLog', '/ns', '/ErrorLog: .\TCErrors.txt'
#$arguments=$project, '/run', '/PrjVar:InrExeLocation="$(Agent.Releaseagent)\_TNR\TNR Binaries\tnr.exe"', '/exit', '/DoNotShowLog', '/ns', '/ErrorLog: .\TCErrors.txt'
Start-Process -FilePath $testexecute -ArgumentList $arguments



The script in the original post does not invoke the application at all although the TestExecute does run


Thank you





Can we go back one step farther and run TestExecute from a command line prompt without using your script?  We should be able to see test results that way.  If that works, then we can work our way back up to Session Creator.


I tried to run below from the command line and it did start the TestExecute.exe but it did not invoke our application or tests.


TestExecute.exe "C:\ADOAgent\vsts-agent-win-x64-2.181.2_1\_work\r1\a\_INR-IestAutomation\INR_AutomationProjectSuite.pjs"

Are you able to run the tests INR_AutomationProjectSuite.pjs from the TestComplete UI?

Yes, In the TestComplete UI i am able to click on the "Execute Plans" and it invokes the application and my tests.

I see a Run argument in your script but not in the command line attempt.  Can you try that please?

Do you mean this way? 

TestExecute.exe "C:\ADOAgent\vsts-agent-win-x64-2.181.2_1\_work\r1\a\_INR-IestAutomation\INR_AutomationProjectSuite.pjs",'/run'


When i run this it gives me an error saying -:

Invalid command line. The Project Suite 

"C:\ADOAgent\vsts-agent-win-x64-2.181.2_1\_work\r1\a\_INR-IestAutomation\INR_AutomationProjectSuite.pjs",'/run'" was not found


try this


TestExecute.exe "C:\ADOAgent\vsts-agent-win-x64-2.181.2_1\_work\r1\a\_INR-IestAutomation\INR_AutomationProjectSuite.pjs" /r






Showing results for 
Search instead for 
Did you mean: