Ask a Question

Script recording abort with access violation in tcHook.dll

Occasional Contributor

Script recording abort with access violation in tcHook.dll

Hi everyone,


I have an odd problem when recording a script test under Windows 10, TC 11.20, application developed in Delphi 10 Seattle incl. EurekaLog. When I click file -> open in my app, I run an "execute" on the Delphi standard file open dialog. When recording, the dialog does not pop up but I get an "access violation at address 0" in tcHook.dll (image attached). I close the error raised by EurekaLog, stop recording and close the app.


The script created is as follows:


procedure Test1;
var proj_LFH : OleVariant;
var dlgErrorOccurred : OleVariant;
  proj_LFH := Aliases.Proj_LFH;
  proj_LFH.FORM_Main.Click(17, 41);
  proj_LFH.wnd32768.Click(48, 15);
  dlgErrorOccurred := proj_LFH.dlgErrorOccurred;


So the last 3 lines contain the "issue section". Funny thing: when I run this again, the file open dialog pops up as expected, no access violation... So I can "bypass" the problem by dropping those lines and continue recording, but this is not really what it should be like.


Anyone got an idea? Thanks in advance!



Hi prognase,


Based on the error I would check to make sure that you can run TestComplete with Administrator privileges.  With Windows 10 the process for this can be more cumbersome than in previous Windows versions.  More details at the link below.


How do I run an application once with a full administrator access token?



SmartBear Alumni (Retired)

Hi Matthias,


TestComplete does not work well with EurekaLog and similar tools that change the format of the application's debug information. We recommend that you test a version of your application built without EurekaLog. See Complier Settings for Delphi 10 Seattle Applications.


If the version without EurekaLog also has this issue, please contact our Technical Support to troubleshoot this further.

Helen Kosova
SmartBear Documentation Team Lead
Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Occasional Contributor

Dan & Helen,


thanks for your hints, however that so far did not fix the issue but changed the behaviour: when clicking open now, the application does not popup the error message from EurekaLog, instead silently closes as if I had clicked "Exit". I tried both 32bit Debug and Release versions, release including modifications by WinLicense (I suspect also problematic for TC as this heavily modifies the exe incl. vm code creation etc.). But even the clean debug-only shows the problem.


As I didn't have much time for this yesterday and will not during the day today, I will try more this evening. If the issue persists I'll get in touch with Tech Support and provide a URL for the executable so behaviour can be verified.


Thanks for your help!


Occasional Contributor

Just for the record, offender detected: application has an active VCL style. When "turning off" styles by selecting the default "Windows", recording works fine.




Showing results for 
Search instead for 
Did you mean: