Ask a Question

Problem in cross browsing in browser loop

SOLVED
damodarshanbhag
Occasional Contributor

Problem in cross browsing in browser loop

HI, I have got a sudden crash problems with running test cases in IE version 11.096 when i put it in a browser loop by creating a seperate test cases for browser looping and it shows a exception message and a error of IE frames, but the same test cases when i run by changing individual browsers in keyword tests it runs fine in IE. Can anyone suggest me what may be the issue?
8 REPLIES 8
Marsha_R
Community Hero

Yes, we can make suggestions, but you'll have to give us some more information first.

 

What version of TestComplete are you using?

What do you expect your test to do?

What is the exact exception is it showing?

Where exactly in your test is the exception happening?

 

 


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
damodarshanbhag
Occasional Contributor

Hi Marsha

 I am using test complete version 12.0.122

In log file it just shows there is an exception and it stops there and my test cases are checking the web functionality in various browsers , If its run individually by switching the browsers it runs and if its put in a browser loop it fails at the begining.

 

Marsha_R
Community Hero

If you click on the Exception line, is there anything in the Additional Info box?

In the script, ate you opening all three browsers before doing any testing? What happens if you just have the test open one browser, then test, then close it?

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
damodarshanbhag
Occasional Contributor

If i click on exception line the additional info panel shows " specified browser was not found" and my tests are basically keyword tests and it has the options of opening all the installed browsers at once right and it runs on current browser but when it comes to IE it fails, is that a version problem with IE?

Marsha_R
Community Hero

If you run the test individually on IE does it work?

Just curious why you would test with all three open. Would a user do that with your app?

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
damodarshanbhag
Occasional Contributor

Yes it works when its run individually on IE but why the same thing doesn't work when its in browser loop ?

and if i run continously in different browsers  in browser loop it works with chrome, Firefox by opening and closing the browsers and  not IE .

Marsha_R
Community Hero

Okay, then let's take a look at your browser loop code. It's late here so I might not see it till morning but someone else may spot the issue in the meantime!

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
damodarshanbhag
Occasional Contributor

yep, Thank you Marsha.Smiley Happy 

cancel
Showing results for 
Search instead for 
Did you mean: