Ask a Question

Name mapping is slooooowwwww

Super Contributor

Name mapping is slooooowwwww

Last week, the name mapping operation, adding objects to the name mapping has become painfully slow. Has anyone seen this before? I can't think of anything that has changed. The app is the same. TC has not changed...


Apparently, they are aware of git issues now. Reply to my case


Our R&D team investigated the issue, and it seems that the Git integration causes the issue.

When new files are added during the recording, there is the setting that will automatically add them to the repository. So, let's disable that option and check if this improves the situation. To do that, go to "Tools | Options | Source Control | Bind new items to SCC automatically." Then, disable the "Bind new items to SCC automatically" option and try running TestComplete again. 


Turning this option off solved the slow name mapping. I am unclear what features I am losing. If I don't use the source control ui through Test Complete, I am guessing not much.

Turning this option off solved the slow name mapping . Kudos you saved my lots of time. 🙂

Weeeellllll.... what about people who want to use this feature? I am not sure this is a great solution.

True, disabling the feature means they don't get things automatically bound... however, you can still MANUALLY bind items to SCC via the right-click context menu.  It's an extra step, but not critical.  I expect that the SmartBear folks will be working on figuring it out so we SHOULD get a patch sometime  in the future.

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

AND since it is a machine option, as is sensible, when you change from TC 1x to TC14, you have to reset the options. Ask me how I know. 🙂

Bumping to inquire if anyone knows whether or not this has been fixed.

Yeah, that the actual issue that I also faced. However, closing unused sys process can also helps sometimes 🙂


Showing results for 
Search instead for 
Did you mean: