Ask a Question

Inconsistent VM screen resolutions

dhundley
Contributor

Inconsistent VM screen resolutions

The machines that we do TestComplete development on have screen resolutions of 1920x1080. The VMs where TestExecute runs our automation seem to be unable to maintain that setting. We continually have to open tickets with our help desk folks to reset the display settings but eventually they get "off" again and our tests will start to fail because a mouse click is being attempting at invalid coordinates that might now even be off the edge of the screen or overlapped by another part of the UI because the new screen res setting doesn't allow the whole page to be in view. Does testcomplete offer any way to work around this type of scenario? thanks!

10 REPLIES 10
AlexKaras
Community Hero

Hi,

 

TestComplete itself does not provide such functionality.

If your tests are executed via CI\CD, then you may use command/plugin/etc. that provides display resolution adjustment for your given CI\CD server (e.g.: https://support.smartbear.com/testcomplete/docs/working-with/integration/azure/test-adapter/build-pi...).

If your tests are executed locally, you may consider some third-party tool and execute it before your tests (e.g.: https://superuser.com/questions/89302/any-way-of-changing-windows-screen-resolution-via-command-line)

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
rraghvani
Valued Contributor

I've had the same issue before. Ensure the VM has appropriate video memory size, and if you use SessionCreator, you can maintain the screen resolution by using the parameter /ScreenResolution:"1920*1080".

 

Thank you for the information. I will pass your ideas onto our internal support group and see what they say about it. I'll update this post when i hear back from them. 

jrsbr
New Contributor

We had issues with this.  We had to run TestComplete as administrator to enable it to effect resolution changes on the VM host.  Also in line with @rraghvani  the VM host has to have sufficient video resources.  A lot of VM hosts have very basic resolutions like 800x600, 1024x768 etc  We did get it working tho.

when you say "run testcomplete <testexecute in my case> as administrator to enable it to effect resolution changes on the VM host" can you elaborate a bit more as to how, exactly, resolution changes can be effected by testexecute? when i'm on my VM (with administrator privileges) i can't even display the resolution settings. 

 

 

dhundley_0-1674569746118.png

 

rraghvani
Valued Contributor

Check the following settings

rraghvani_0-1674574027098.png

 

If you use a different application to connect to your VM, then you'll have to check the settings.

We don't actually use the basic windows Remote Desktop connection to RDP into our VM's. Rather, its RDWeb (or Remote Desktop Connection Manager v2.7). It's display settings screen looks like this

dhundley_0-1674574463057.png

 

rraghvani
Valued Contributor

A quick internet search shows this, https://community.spiceworks.com/topic/1212082-remote-desktop-connection-manager-screen-size. I guess you need to change your RDWeb settings.

I tried setting it the way described in the link and that had no effect either. I'm in a conference call with our support desk and the VM software vendor on Thursday. Hopefully, we'll have the answer to this question after that. I will update this post once that meeting has taken place and let you know if we came up with any solutions. thanks for all the suggestions. 

cancel
Showing results for 
Search instead for 
Did you mean: