Ask a Question

I get an "Unavailable Name Mapping" message and yet my files are there.

New Contributor

I get an "Unavailable Name Mapping" message and yet my files are there.


   I did a "Save Current As" on my Name Mapping Icon to send a co-worker a copy of my Name Mapping files over a transfer server. Now when I open Test Complete, I get an "Unavailable [Name Mapping]" message, yet my original local files are still where they were but Test Complete is looking for them on the transfer server. How can I restore the local path to Name Mapping?




Community Hero



If you are using VCS just revert changes.

Otherwise you can open Name Mapping file from the server and do "Save Current As" again using old location.




-- Make a copy of NameMapping file;

-- Remove NameMapping from your TestComplete project;

-- Add Namemapping a-new;

-- Save project and close it;

-- Overwrite newly created NameMapping file with the saved copy;

-- Open project in TestComplete and check if everything is OK.

  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
Frequent Contributor

I am getting the error Unavailable (Name mapping)

None of my scripts run in Tets complete nor in Test Execute.

Please help.

Last time that I ran the scripts was on Tuesday.Sept 17th , 2019 

I tried to recover but file is not found.I also tried going to the path where all teh files are stored but could not find the file at all.

Do I contact Smart bear?



Showing results for 
Search instead for 
Did you mean: