Ask a Question

How to start a Java Application from (compiled) source

New Contributor

How to start a Java Application from (compiled) source

I tried to start a Java application.


Tested Apps -> new Item -> Java Application


I set the FQN of the class into "Specify application's entry point"


I'm not sure about the difference of "Command-line arguments" and "Enivroment options", so i put my Variables to both.

I have set the Working folder and the class path(s).


But the App don't want to start.


One big problem I am facing is the fact, that the console is open for a very short period only. I was able to read it by multiple starts: he can't find the main class.


Also the app is started by the "java.exe" and not "javaw.exe" which should be user with M$ Windows.


Any suggestions?





Shouldn't "Specify application's jar file" actually specify a jar file?


The docs give a bit more information ( Adding Java and JavaFX Applications to the List of Tested Applications )


oh yes it should.

I just tried, maybe there is a bug in TestComplete 😉

As you can see, the entry point is the same, i ofc tried that first.


edit: It would be realy helpful if i could see the error message for more than 500ms. Is there any way to see a log of it?


edit2: Somehow It's also not possible to change the Java path... i have multiple java versions, but he is only showing 2 (one 32 and it's 64 Bit version)... if i try to change it to some other, he just ignores my selected path.

Showing results for 
Search instead for 
Did you mean: